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  Summary 
This manual describes operating instructions for the K-ROSET .  This manual 
should be read with careful review of the related manuals listed below. Once the 
contents of all the manuals are thoroughly read and understood, the robot can be 
used. 
 
1. Robot Instruction manual 
2. Option Manual 
3. AS language reference Manual 

The contents of this manual are described on condition that installation and 
connection of the robot are done in accordance with the above listed manuals. 

This manual provides as much detailed information as possible on the standard 
operating methods for the Kawasaki robot.  However, not every possible operation, 
condition or situation that should be avoided can be described in full.  Therefore, 
should any unexplained questions or problems arise during robot operation, please 
contact Kawasaki Machine Systems.  Refer to the contact information listed on the 
rear cover of this manual for the nearest Kawasaki Machine Systems office. 

The explanations in this manual include information on optional functions, but 
depending on the specification of each unit, not every optional function detailed here 
may be included with the robot.  Also, note that figures given here may differ 
partially from actual screens. 
 
 

1 This manual does not constitute a guarantee of the systems in which the robot is 
utilized.  Accordingly, Kawasaki is not responsible for any accidents, damage, 
and/or problems relating to industrial property rights as a result of using the 
system. 

2 It is recommended that all personnel assigned for activation of operation, teaching, 
maintenance or inspection of the robot attend the necessary education/training 
course(s) prepared by Kawasaki, before assuming their responsibilities. 

3 Kawasaki reserves the right to change, revise, or update this manual without prior 
notice. 

4 This manual may not, in whole or in part, be reprinted or copied without the prior 
written consent of Kawasaki. 

5 Store this manual with care and keep it available for use at any time.  If the robot 
is reinstalled or moved to a different side or sold off to a different use, attach this 
manual to the robot without fail.  In the event the manual is lost or damaged 
severely, contact Kawasaki. 

Copyright © 2011 Kawasaki Heavy Industries Ltd.  All rights reserved. 



 
 

  Safety Instruction 
The items that require special attention in this manual are designated with the 
following symbols. 

 

Ensure proper and safe operation of the robot and prevent physical injury or 
property damage by complying with the safety matters given in the boxes with these 
symbols. 
 
 
 

 

 

 

 

 

 

 

 

 

 
 
 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 

 

[NOTE] 

Denotes precautions regarding K-ROSET specification, 
handling, teaching, operation and maintenance. 
 

1. The accuracy and effectiveness of the diagrams, procedures, and 
detail explanations given in this manual cannot be confirmed with 
absolute certainty.  Should any unexplained questions or 
problems arise, please contact Kawasaki Machine Systems. 

2. Safety related contents described in this manual apply to each 
individual work and not to all robot work.  In order to perform 
every work in safety, read and fully understand the safety manual, 
all pertinent laws, regulations and related materials as well as all 
the safety explanations described in each chapter, and prepare 

      
 

WARNING  
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1  Introduction 
K-ROSET is an offline programming application for creation of teaching programs and simulation 
of Kawasaki Robot. HISUI is used for a view function. 
This section describes an environment, installation method and a license necessary for the 
K-ROSET. 
* HISUI is an OpenGL framework created by QUATOUCH Inc. 

1.1 License key 

License File 

A license file issued according to the information peculiar to the target PC 
( KROSET_License.key) is necessary to start the K-ROSET.  When the suitable file doesn’t exist 
in the installation folder, the K-ROSET does not start properly. Apply for a license file according 
to the attached document "Application for K-ROSET license file. pdf." 
 
A license protection feature using a USB key is also contained. Call your nearest sales department 
for the details. 
For starting Plug-in application, an additional key may be necessary. When a license of an optional 
function is necessary, contact us. 

1.2 Operating environment of K-ROSET 

The PC operating environment necessary for operating K-ROSET is shown below. 
 

Item Details 

Operating System（OS）*1 
 

Windows XP Professional x86 SP3/x64 or higher 
Windows Vista x86 SP3/x64 SP1 or higher 
Windows 7 Professional x86/x64 SP1 or higher 

CPU Intel, AMD 2GHz(32bit) or higher 

RAM 
1-2 GB or more 
The virtual memory is recommended to be twice as large as RAM 

Storage device 500MB or more 

Disk device CD,DVD drive 

Video Card 
A combination of a verified OpenGL workstation video card and its 
driver. 

Other requirements 

A Mouse (Recommendation: mouse with a scroll wheel) or equivalent 
pointing device 
Internet Explorer version 6.x or higher 
Adobe® Acrobat® Reader 

*Windows® is registered trademarks of Microsoft Corporation. 
*Adobe Reader ® is registered trademarks of Microsoft Corporation. 
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1.3Install and Uninstall 

For the details on installation and uninstallation, refer to "K-ROSET Installation Guide_EN .pdf" 
in the CD-ROM. 

 
 

1.4Concept and Terms 

 
This chapter describes a concept and terms of K-ROSET used in the main text. 

 

1.4.1Concept 

This chapter describes an idea of K-ROSET. A screen of K-ROSET is displayed below. 

 
 
 

The screen of K-ROSET consists of a main screen, layout, view, and a task panel. 
The roles of the screens are shown below. 

 

Layout View Layout Main 
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Screen name Role 
Main A menu and a tool bar of the view are displayed. 
Layout Basic screen. Addition and change of models can be carried out on this 

screen. Select a model, right-click to show a menu, and set a necessary 
setting for the model. 

View Screen to display a model. The screen can be displayed in three 
dimensions. In addition, a viewpoint can be changed, and a model can be 
dragged to move. 

Task panel This panel mainly displays extended applications. According to work 
details, only necessary screens can be displayed. Floating display from 
the task panel can also be carried out. 

 

Right-click menu 

In K-ROSET, operations such as opening a project and addition of a robot are carried out from a 
layout screen or a view screen. Refer to a screen below. Addition of a work to a project is shown. 
The operations for this addition are as follows: 
 

1 Right-click a project icon. 
  A menu is displayed, and a menu related to the project is displayed. 

2 Select [Add] -> [Environment] -> [Work]. 
  The file dialog box is displayed. 

3 Select a work file. 
 

 

1.4.2Coordinate system 

 
This section describes converted coordinate values. Converted coordinate values indicate the 
coordinate values of a coordinate system created around certain coordinates serving as an origin. 
Coordinate values consist of six values, which are three values indicating the position and three 
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values indicating the orientation, and are generally expressed as (X, Y, Z, O, A, T). Converted 
coordinate values are classified into four variations: world coordinate, local coordinate, tool 
coordinate, and base coordinate. Each of these is described below. 

 
 

World coordinate system 
 

A coordinate system having its origin at the world origin. This coordinate system is an absolute 
coordinate system. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Local coordinate system 
 

A coordinate system having its origin at the center of gravity of the object. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

World origin (0, 0, 0) 

World origin (0, 0, 0) 
 

Model origin (0, 0, 0) 
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Tool coordinate system 
 

A coordinate system having its origin at the tool origin of the robot. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Base coordinate system 
 

A coordinate system having its origin at the origin of the base coordinates. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

Tool origin (0, 0, 0) 
 

 

Base origin (0, 0, 0) 
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1.4.3Libraries and CAD files 

 
The 3D data format used for Hisui version is STL. 
The STL is widely used as a triangular mesh solid display file format to display 3D models. The 
3D model data recorded are a surface normal vector of triangle and the coordinate value of three 
vertexes. 
 
The order of the three vertexes and the relations of the front and back faces comply with the rule of 
right-hand screw. 
The STL file format has Ascii format and a binary format. 

 
 

1.4.4K-ROSET configuration 
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1.4.5Folder structure 

Folder configuration of the K-ROSET is described. 
 

MyKHIlibraries 
The K-ROSET creates MyKHIlibraries folder in My Documents of the log in account when 
installed. 
Example) User is OLP 
C: ¥Documents and Settings¥OLP¥My Documents¥MyKHIlibraries 
This folder is a default folder for the file selection dialog opened for saving/reading the project and 
the trace file created by you. 

 
 

KHIlibraries 
(Installation folder)¥Kawasaki¥K-ROSET¥Hisui¥KHIlibraries) 
Sample project and library provided from us are contained in this folder. 
We recommend that the file that created by you should be saved in the above-mentioned 
MyKHIlibraries folder. 
* The installation folder may be changed without notice. 



8 

  

 Memo 
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2  Operation of View 
This section describes an operation of view for Hisui. 
The operation can be carried out with an icon or view menu. 

 

 

 

 

2.1View Operation with a Mouse 

 

Rotation Press a right button on a mouse to drag a view. 
Pan Press Shift key and a right button on a mouse 

to drag a view. 
Zoom Three methods are available: 

(a). Press Ctrl key and a right button on a 
mouse to drag a view. 
(b). Zoom with a mouse wheel. 
(c). Drag with a central button on a mouse and 
draw a rectangle to zoom the rectangular 
region. 

Partial Zoom - In Click the object with a central button on the 
mouse to move the fixation point to the 
position. This operation enables the control a 
center of rotation of the view. In addition, the 
fixation point (center of rotation) is also set to 
the destination of the zoom in the zoom 
operation (c). 

 

 

2.2Restore a View Point/Undo 

When a display of the model is changed, the display can be restored or undone. 

Restore   
Click Restore view point. 

Undo     
Click Undo view point. 

 
 

View menu 
 

Icons 
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2.3Fit 

A model is displayed in the view perpendicular to a visual line. 

1 Click Fit.  

A model is adjusted automatically so that the entire model can be displayed within the view from 
the point of view when the mouse is clicked. 

2 Select XY / YZ / ZX. 

A model is displayed in the view perpendicular to a visual line. 
 

                

 

2.4Clip Plane ON/OFF 

A cross section of the model is displayed. 

 
 

1 Click Clip ON/OFF icon.  

Each click switches ON/OFF. 
Display a menu list of Clip plane ON/OFF to select a side to cut. 
Select the plane as a standard of the Clip plane from the list. 
Moving with dragging the plane can decide a cross-sectional position. 
 

XY plane ZX plane YZ plane 
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2.5Both side Front side  

Display of wire frame is switched. 
 

[ ] Both Side   …Wire frame of the rear side is also displayed. 
[ ] Front Side   …Only wire frame of the front side is displayed. 

 

2.6Displaying Style 

Displaying style of the model is controlled. 
 

[ ] Shading   …A model is displayed in shading (default display). 
[ ] Wireframe   …A model is displayed with a wire frame. 
[ ] Shading＋Wireframe  …A model is displayed in shading and with wiring. 

 
 

 
 
 
 
 

 

 

 

              Shading         Wire frame      Shading+Wire frame 
 

2.7View Setting  

A projection method is switched. 
 

[ ] Ortho …Display method projected parallel to a view. 
[ ] Perspective …View with a depth (a view usually seen from human eyes). 
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2.8Show axis 

An origin of the world coordinate is displayed 
with an arrow. 
Red is for X, green for Y, and blue for Z. 
The hide/show of the coordinate axis is 
switched. 

 
 
 
 

1Click the display of the coordinate axis of 
the view menu to place a check mark. 
Display the coordinate axis. Click when a check is marked to the coordinate axis display menu. 
The display is unchecked and the coordinate axis disappears. 

 

2.9Show compass 

A compass displays the direction of the 
world coordinate. 
The hide/show of the compass is switched. 
 
 

1Click the compass display of the view 
menu to place a check mark. 
Display the compass. 
Click when a check is marked to the compass 
display menu. The display is unchecked and 
the compass disappears. 

 

 

 

 

2.10Show ruler 

Ruler is scale displayed in a view. 
The unit is mm. 
The hide/show of the ruler is switched. 
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1Click the ruler display of the view menu to place a check mark. 
Display the ruler. 
Click when a check is marked to the ruler display menu. The display is unchecked and the ruler 
disappears. 

2.11Save and Copy as image 

Images of the view can be saved/copied. 
 
[ ] Save an image …A view in display is named and saved into an arbitrary position. 
[ ] Copy an image …A view in display is saved into a clipboard. 

 

 

2.12Setting 

A background color of the view, a default color of the model (non-selected), and the color of the 
background are set. 
 

1Click [ ] from a tool bar of the view, or select the setting of the view menu. 
A view setting screen on the right is displayed. 
Various kinds of setting can be carried out. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

The setting frequently used is described. 

★ Color 

A color of all models when the color is not selected can be changed. 
Click a numeric value next to Color to display a list selection button. Click the button. 
A color setting screen below is displayed. 
The colors can be selected from custom/Web/system tabs. 
The colors of all models change. 
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★ BackGroundColor 

Click a numeric value next to Color to display a list selection button. Click the button to change. 

2.13Split Screen of View 

The view is displayed in split screens. 
 
[ ]Single view      …Display in a single view. 
[ ]Double views  …Display in dual (right and left) views. 
[ ]Quad views   …Display in tetrahedral (top, bottom, right and left) views. 
[ ]Show current view …The currently selected view is surrounded in a red frame 
      for easy recognition of the currently selected view among split 
views. 

［ ］全ビュー  ・・・拡大縮小の操作を全ビューに適用します。 

1Click the applicable icon. 
The screen is switched to the selected view. The background of the selected icon turns orange. 
The figures below show a dual view and a tetrahedral view. 
 

 
 
 
 
 
 
 
 
 

              Dual view      Quad view 

2.14Click Action 

Clicking the view, an action is set. 
 

[ ]Select Object    …Select clicking models. 
[ ]Adjust View  …Adjust the clicking surface. 
[ ]Quad views  …Center the clicking point. 
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1 Click [ ] from a tool bar of the view. 
A menu list is displayed. 
Various kinds of setting can be carried out. 

  
 

2.15Zoom 

A center of zoom of the view is set. 
 

[ ]View Center      …Zoom a center of the view.. 
[ ]Mouse Position  …Zoom a mouse point. 
 

1 Click [ ] from a tool bar of the view. 
A menu list is displayed. 
Various kinds of setting can be carried out. 
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 Memo 
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3  Basic Function 

3.1Screen Configuration 

Main screen of K-ROSET 
 

This chapter describes basic terms and concepts concerning the robot and offline programming of 
K-ROSET 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Layout  View Task Panel 
k 
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The main screen of K-ROSET consists of the following three major sub-screens. 
Object tab (tree pane, properties pane) 
View pane 
Extended application pane (program table, etc.) 

 
The function of each element is described in the following sections. 

3.2Menu 

This section describes menu and tool bars. 

 

3.2.1Setting 

Plug-in setting menu can be selected. 
 

    
 
 

 

(1) 
(2) 

(3) 

(4) 

(5) 

(6) 
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★ (1) Tab 

As for the system tab, our plug-in application (called as extended application) is displayed. 
The application created by customer can be registered into user tab. 

★ (2) Function 

A function name of the extended application is displayed. 
Check the box for enabling the function, and uncheck for disabling. 
When checked, application is loaded immediately. 
After uncheck, make sure to restart. 

★ (3) Floating 

When checked, a screen in the application will float to be displayed.  

★ (4) Description 

The description of each function is displayed. 

★ (5) DLL 

The file name of each function is displayed. 

★ (6) Version 

The version of each function is displayed. 

3.2.2Help 

Version information of K-ROSET is displayed. 
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Select version information from help menu. 
The screen below is displayed. 
The version, logo, and license agreement are displayed. 
<Version display> 

3.2.3Plug-in 

Plug-in application is selected. 

 
 

Click the plug-in menu. 
The available menu is displayed. 
The alignment sequence of the menu follows the order of adding functions. 
The description of each plug-in function is described in Chapter 4 Plug-in Application. 
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3.3Layout Tab                                                                                                                                

This section describes the object tab. 
The object tab consists of the tree and properties panes. 
 
Tree pane: Usable to create, read-in, or save a project, and add, change, or delete various items. 
 
Properties: Usable to change item parameters. 

★ Tree pane 

The tree pane includes two types of items: physical (existing) items having a real form and logical 
items not having a real form (data only). 

 

★ Physical items 

Icon Node Description 

 Robot The robot. 
Consists of several items such as the base and joint. 

 Base One of the robot component items, which is the base of the 
robot. 

 Joint One of the robot component items, which works as a joint of 
the robot. 

 Tool One of the robot component items, which is installed at the 
end of the robot arm to perform work such as painting or 
grasping depending on the tool type. 

 Workpiece An item to be the target of work such as painting or grasping. 
Parts etc. are applicable. 

 Obstacle An item out of the target of work such as painting or grasping. 
Part stands etc. are applicable. 

 

★ Logical items 

Icon Node Description 

 Flange One of the robot component items, which connects the arm 
end with the tool. 

 Logical 
joint 

One of the robot component items, which is a joint to control 
the robot’s motion on the PC side. 

 Teaching 
point 

A point to be used as a reference for work. 

 Group Two or more items can be managed as a single group. 

★ Option terms (Example: Workpiece)Option *Example : Work 

Icon Node Description 

 Hide A state that the model is hidden 

 Lock A state that the location of model is locked. 

★ Properties pane 

The properties pane is used to browse or change various item parameters in the project. (Some 
parameters do not accept changes.) 
Parameters that can be browsed or changed are shown below. 
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★ Project 
Parameter Change Description 
Project Name O Project name 
Protect O  
Version  Project version 

 

★ Robot 
Parameter Change Description 
Name O Item name 
Product Type  The model code of the robot 
Lock O Place change is invalidated 
World Trans O World coordinate values 
Local Trans O Local coordinate values 
Joint value O Value of each joint *1 
Base Trans O Base coordinate values 
Deactivate Collision 
Detection  

 Whether the item is applicable to interference check or not 
is indicated. 

Entity Type  The type of the item is indicated. 
Show Origin O Whether the origin of the item is displayed or not is 

indicated. 
Shape File Path  The absolute path to the shape file is indicated. 
Visible O Whether the item is displayed or not is indicated. 
Tool Trans O Tool coordinate values 

 
 

★ Base 
 
 
 
 
 
 
 
 
 
 
 
 
 

★ Joint 

Parameter Change Description 
Axis No  The joint number is indicated. 
Deactivate Collision 
Detection 

 Whether the item is applicable to interference check or not 
is indicated. 

Entity type  The type of the item is indicated. 
Local Trans O Local coordinate values 
Name O Item name 
Show Origin O Whether the origin of the item is displayed or not is 

indicated. 
Shape File Path  The absolute path to the shape file is indicated. 
Joint value O Value of each joint *1 
Visible O Whether the item is displayed or not is indicated. 
World Trans O World coordinate values 

Parameter Change Description 
Show Origin O Whether the origin of the item is displayed or not is 

indicated. 
World Trans O World coordinate values 
Deactivate Collision 
Detection 

 Whether the item is applicable to interference check or not 
is indicated. 

Visible O Whether the item is displayed or not is indicated. 
Entity type  The type of the item is indicated. 
Name O Item name 
Shape File Path  The absolute path to the shape file is indicated. 
Local trans O Local coordinate values 
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★ Tool 
 

 
 

★ Work-piece, obstacle 

World Trans O World coordinate values 
Local Trans O Local coordinate values 
Grip Attribute  Whether the item is grasped or not is indicated. 
Deactivate Collision 
Detection 

 Whether the item is applicable to interference check or not 
is indicated. 

Show Origin O Whether the origin of the item is displayed or not is 
indicated. 

Shape File Path  The absolute path to the shape file is indicated. 
Visible O Whether the item is displayed or not is indicated. 

 
★ Flange 

 
 
 
 
 
 

★ Logical joint 
Parameter Change Description 
Deactivate Collision 
Detection 

 Whether the item is applicable to interference check or not 
is indicated. 

Entity type  The type of the item is indicated. 
Lock O Place change is invalidated 

Local Trans O Local coordinate values 
Name O Item name 
Show Origin O Whether the origin of the item is displayed or not is 

indicated. 
Shape File Path  The absolute path to the shape file is indicated. 
Joint value  Value of each joint *1 
Visible O Whether the item is displayed or not is indicated. 

Parameter Change Description 
Name O Item name 
World Trans O World coordinate values 
Local Trans O Local coordinate values 
Local trans of Tool 
Arrow 

O Local coordinate values of tool end 

Tool Trans O Tool coordinate values 
Deactivate Collision 
Detection 

 Whether the item is applicable to interference check or not 
is indicated. 

Entity type  The type of the item is indicated. 
Show Origin O Whether the origin of the item is displayed or not is 

indicated. 
Shape File Path  The absolute path to the shape file is indicated. 
Visible O Whether the item is displayed or not is indicated. 

Parameter Change Description 
Name O Item name 
Entity type  The type of the item is indicated. 
Lock O Place change is invalidated 

Parameter Change Description 
Name O Item name 
Entity type  The type of the item is indicated. 
World Trans O World coordinate values 
Local Trans O Local coordinate values 
Preset Trans O Recorded coordinate value 
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World Trans O World coordinate values 
 

★ Teaching point 
 

 
★ Group 

 
 
 
 
 
 
 
 
 

 *Joint values exceeding the movable range can be entered when they are changed in the 

properties pane. 

3.3.1Project  

A project is constructed by placing these objects and arranging them in predetermined positions. 
Objects to be arranged include the robot, workpieces, and obstacles. 

 

3.3.1.1Creating a new project 

Make sure to save a project before this operation. 

1 In the tree pane, right-click the project icon [ ]. 
The view is cleared, and the project setting screen is displayed. 
 

2 The project menu will be displayed. Select [Project] -> [New]. 
The project setting screen is displayed. 

 *When the model has already been displayed, the confirming message is displayed. 

 

Parameter Change Description 
Converted local 
coordinate values of 
teaching point 

O Local coordinate values of a teaching point as a reference 

Converted world 
coordinate values of 
teaching point offset 

O World coordinate values of a teaching point offset 

Converted local 
coordinate values of 
teaching point offset 

O Local coordinate values of a teaching point offset 

Entity type  The type of the item is indicated. 
Name O Item name 
Converted world 
coordinate values of 
teaching point 

O World coordinate values of a teaching point  as a reference 

Parameter Change Description 
Name O Item name 
Entity type  The type of the item is indicated. 
Lock O Place change is invalidated 
World Trans O World coordinate values 
Local Trans O Local coordinate values 
Preset Trans O Recorded coordinate value 



 

25 

 
 

3 Enter a project name in a project name column. Enter the details of the project 
into the comment column. 

4 Press OK button. 
The project with the specified project name is newly created. 

 

3.3.1.2Reading in a project  

 
Make sure to save a project before this operation. 
The procedure to read in a project is as follows. 

 
 

1In the tree pane, right-click the project icon [ ].A project reading dialog is displayed, 
and then the file saved in the past is displayed. 
Specify a file and read The project file in an arbitrary position can be selected. 
Delete The project selected in the preview is deleted. 
Read The project selected in the preview is read. 
Cancel The project reading screen is closed. 
Display mode The display method of the preview is changed. 

Preview, icon, the detailed display can be selected. 
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The project menu will be displayed. Select [Project] -> [Read-in]. 
A dialog to read files will be displayed. Thumbnails of the project saved by [Save Speedy] are 
shown. 
Read the project by selecting it. The selecting way is as follow. 

2Select arbitrary project in the preview, and click the read button. 

3A confirm dialog to read the project is displayed. 

4Click YES to read the project. Click NO to cancel reading. 
 
 

3.3.1.3Saving a project  

The procedure to save a project is as follows. 
 

 

1 In the tree pane, right-click the project icon [ ]. 

2 The project menu will be displayed. Select [Project] -> [Save]. The project setting 
dialog is displayed. 

3 Enter the name of the project to save. Enter remarks if necessary. 
Select [OK]. 

 
Save Specifies a new file name, and saves files including a model file. 

Creates a folder with the specified project name to save. 
Overwrite Saves the opened project in the original project folder without 

change. 
A dialog to save files will be displayed. Select the destination folder and the file name to be saved, 
and press the [Save] button. 

★ *Make the new folder for model before saving the model. 
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3.3.2User Operations Common to Robot, Workpieces, 

and Obstacles 

This section describes the user operations common to the robot, workpieces, and obstacles. 
 

3.3.2.1Showing/Hiding 

This section describes how to switch display between showing and hiding. 
A state hidden the model is displayed by [ ]. 
 
In the tree pane, right-click the workpiece icon [ ]. 
A menu is displayed. Click [View]. 
The check mark [ ] indicates that the object is being displayed. 

 

3.3.2.2Highlighting 

This section describes how to highlight on the view. 
 

1 Left-click the work icon [ ] in the tree pane. 
 

3.3.2.3Locking/Unlocking 

This section describes how to switch between lock and unlock. 
A state locked the position of the model is displayed by [ ]. 
 

1 In the tree pane, right-click the work icon [ ]. 

2 Menu is displayed. Click the [Lock]. 

 *A state locked is check mark such [ ]. 

 

3.3.2.4Showing/hiding the origin 

This section describes how to switch between show and hide of the origin. 
 

1 In the tree pane, right-click the work icon [ ]. 

2 Menu is displayed. Click the [Show origin]. 

 *A state locked is check mark such [ ]. 
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3.3.2.5Repositioning a robot 

This section describes procedures to reposition a robot added to the project. 
To reposition the robot, perform one of the methods below. 
 

★ Changing in the tree pane 

In the tree pane, double-click the robot icon [ ] to open the reposition dialog box. 

    
 

Manually enter or use the slide bar to adjust each coordinate value. 
To apply the settings that you set up, press the [Apply] button. To return to the former settings, 
press the [Undo] button. 
Once the Apply button is pressed, the former settings before change cannot be returned to. 
Current position Z shows the value of distance from the surface of grid display to the origin of the 
base coordinate. 

 

★ Changing from the robot menu 

In the tree pane, right-click the robot icon to select [Position] -> [Change] from the menu to open 
the reposition dialog box. 
Follow the procedure of method (1). 

 

★ Changing from the view 

In the view pane, double-click the robot model to open the reposition dialog box. 
Follow the procedure of method (1). 

 

★ Changing from the properties pane 

In the tree pane, select the robot icon. 
In the properties pane, change the converted local coordinate values. 
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3.3.2.6Using Undo Relocation to restore former coordinates 

The robot can be restored to the previous coordinate values using Undo Relocation, which is an 
extended application. 
 
Please refer for detail to chapter of Undo Relocation function. 

 
 
 

3.3.2.7Drag and drop in tree pane 

Drag and drop each object in the tree pane creates a parenting relationship. 
 

 * The model only changes the configuration of layout and doesn’t move on the view, because 

the world coordinate is taken over. 

 

    
 

 

3.3.2.8Selecting Model file 

This section describes the model selection dialog to add works and obstacles. 

 
 

The dedicated dialog to open the models such as environment or tool is displayed in K-ROSET. 
A shortcut of [MyKHIlibraries] and [KHIlibraries] are displayed in the dedicated dialog. 
* Refer to the folder configuration for the folders. 
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3.3.2.9Setting of color/transparency  

This section describes color/transparency setting for shape files such as works, obstacles, and robot 
axis models. 
As right-click the node of the shape file in the tree pane, then it is display the items of color and 
transparency in the menu. 

 

   

 

★ Setting of the color 

Select "Color" of the menu to display a color palette. 
Select a color to change and press OK to reflect in the view. 

 

★ Setting of the transparency 

Select "Transparency" of the menu to display a transparency setting screen. (Default value is 255.) 
Change transparency in a bar to reflect in the view. 
Close with the Close button or "X" to fix transparency. 
Press the button "Return" to cancel the change and return to original transparency. 
(Example) J2 ... transparency: 100 / J3 ... color: Black / Work ... color: Brown Transparency ... 120 

   
In K-ROSET, the special dialog is to open a model of an environment, a tool and so on.  
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Shortcuts, [MyKHIlibraries] and [KHIlibraries], are shown in the special dialog. 
*Reference: folder configurations 

 

3.3.3Robot 

This section describes how to add a robot to the project. 
 

3.3.3.1Adding a standard robot 

This section describes how to arrange a robot in a project. 
 
In the tree pane, right-click a project icon [ ] to select [Add] -> [Robot] from the menu. 
The robot selection dialog box will open. Select the robot’s model, controller, and Application, and 
press the [OK] button. 

   
The designated robot is added to the origin after the button is pressed. 

 

3.3.3.2Adding a custom robot 

In the tree pane, right-click the project icon [ ] to select [Add] -> [Robot] from the menu.  
  
The robot selection dialog box will open. Change the Library Type into [Custom]. Select the 
robot’s model, controller, and Application, and press the [OK] button. 

   
When adding a robot, the reposition dialog box can be displayed. 
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In the tree pane, right-click the project icon [ ] to select [Settings] from the menu. The basic 
application GUI setting dialog box will appear. 

   
 

Select [Yes] at the [View reposition dialog box] item, and press the [OK] button. The view position 
dialog box will appear every time a robot is added hereafter. 
 
The tool and base arrows can be resized. 
It is also possible to add a robot from the design library by the drag and drop operation. 

 

3.3.3.3Repositioning a robot 

This section describes procedures to reposition a robot added to the project. 
To reposition the robot, perform one of the methods below. 
 

★ Changing in the tree pane 

In the tree pane, double-click the robot icon [ ] to open the reposition dialog box. 
Manually enter or use the slide bar to adjust each coordinate value. 
To apply the settings that you set up, press the [Apply] button. To return to the former settings, 
press the [Undo] button. 
Once the Apply button is pressed, the former settings before change cannot be returned to. 
Current position Z shows the value of distance from the surface of grid display to the origin of the 
base coordinate. 

 

★ Changing from the robot menu 

In the tree pane, right-click the robot icon to select [Position] -> [Change] from the menu to open 
the reposition dialog box. 
Follow the procedure of method (1). 

 

★ Changing from the view 

In the view pane, double-click the robot model to open the reposition dialog box. 
Follow the procedure of method (1). 

 

★ Changing from the properties pane 

In the tree pane, select the robot icon. 
In the properties pane, change the converted local coordinate values. 
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3.3.3.4Deleting a robot 

This section describes the procedure to delete a robot. 
 
Right-click the robot to be deleted. 
A menu will be displayed. Select [Delete]. 

 

 
 

3.3.3.5Display a grouping robot constitution 

This section describes how to show the joint of the robot in the state of not tree but term. 
 

 

 

1. Group show 2. Tree show 
 

In the tree pane, right-click the robot icon and select [Show axis on group status] from menu. 

 *Initialize state show group status. 
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3.3.3.6Switching the current robot 

This section describes the procedure to switch the current robot in a project having multiple robots. 
 

In the tree pane, select the target robot to be made the current one. 
 

3.3.3.7Arm Settings 

This section describes how to set the arm of the robot. 
A method to set mechanical information of the robot is described. 
The setting of the arm number, system, and auxiliary data can be edited. 
The screen can start from layout and a program table. 
 

★ Start from Layout 

Right-click the robot icon. 
Select [Arm setting]. 
 

★ Start from Program Table 

Display a robot node menu of the program table, and select [Arm Setting]. 
Controller and arm are displayed in tree structure, and the arm setting can be displayed from a 
controller setting screen. 

 

Setting the number of the robot and editing and deleting the tag data can be performed. 

 
 

Registering the installation of a robot 
This section describes the procedure to specify a place to install the robot (floor, ceiling, etc.) 
In the program table, select [Arm Settings] from the arm menu. 
Change the [Register Installation] item on the arm settings screen. 
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Installation can be registered by selecting from “floor,” “ceiling,” “wall” (facing downward), or 
“wall (reversed)” (facing upward) according to the place where the robot is installed. 
 
A confirmation dialog is shown to synchronize the setting in Arm setting with PC-AS after 
clicking [Apply]. 

 
★ Expand Item  

UP-LIM Upper limit value of a axis LO-LIM Lower limit value of a axis 
HOME Initial coordinate TOOL Tool trans. 
CVDIRECT Conveyor direction   

 

3.3.3.8Controller setting 

11. Right-click the controller of the program table to display a menu. 

2Select [Controller setting]. 

3Controller setting can be displayed from the controller and the arm setting screen. 
AS Version PC-AS version of the controller is displayed. 
Controller Type The type of the controller is displayed. 
Application Application of the controller, such as 

painting/standard/arc welding, is s displayed. 
Arm Number The number of robots operated by one controller is 

displayed. 
AS Cycle The control period of the robot controller is displayed at 

msec. 
Language The language setting of the robot controller is changed. 

When changed, make sure to restart. 
AS link support condition Execution of PC - AS is displayed. Enabled for bootable, 

and Disabled for unbootable. 
 

★ Controller name menu of the tree 

Right-click on the controller name [C**] of the [Controller/Arm setting] to display the controller 
menu. 
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Connection Start/exit the PC-AS from context menu of the controller name of 
the tree pane. 
* Check mark is placed when PC - AS has been started. 

Change of access level Editing operation level of the [Controller/Arm setting] is changed 
from context menu of the controller name of the tree pane. 
[Guest User] ...... Usual 
[Power User] ...... Access unlimited. (Same as the actual controller, 
the predetermined password is necessary.). 
* Please contact us for details. 

A confirmation dialog is shown to synchronize the setting in Controller setting with PC-AS after 
clicking [Apply]. 

3.3.3.9Hand guide display 

Batch switching of hide/show of the origin of the teaching point/base coordinate/tool coordinate is 
carried out. 

3.3.4Workpiece 

This section describes the installation method of workpieces. 

3.3.4.1Adding a workpiece 

This section describes the procedure to add a workpiece. 

1In the tree pane, right-click the project icon [ ]. 
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2The project menu will be displayed. Select [Add] -> [Environment] -> [Work]. 

3The file selection dialog box will appear. Select the target file, and press the [Open] 
button. 
 
An icon of the work [ ] is added to the tree pane on the left side of the screen, and a model of the 
added workpiece appears in the central view pane. 
 
The folder of frequently used models can be added from the design library. Click Add File 
Location in the design library to add the folder. 
The models displayed in the design library on the right side of the screen can be added by the 
drag-and-drop operation. 
 
For details, refer to Help. 
 

3.3.4.2Changing the workpiece position 

This section describes the procedure to change the workpiece position. 
 

1Double-left-click the added workpiece icon [ ] in the tree pane. 

2The reposition dialog box will appear. Manually enter settings or use the slide bar to 
change the coordinate values. 

3Press the [Apply] button to reflect the change, and press the [Close] button to close the 
dialog box. 
 
The reposition dialog box can also be displayed by double-clicking the workpiece model in the 
view pane, or by selecting [Position] -> [Assigned Position] from the menu of the workpiece 
instead of double-left-clicking the workpiece icon. 

 
Move with Triad 
This can be changed the position of models in the view by using the SolidWorks function. 
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3.3.4.3Deleting a workpiece 

This section describes the procedure to delete a workpiece. 

1Right-click the workpiece to be deleted. 

2A menu will appear. Select [Delete]. 
 

3.3.4.4Recording a workpiece position 

This section describes the procedure to record a workpiece position. 

1Right-click the workpiece [ ] to be recorded in the tree pane. 

2The workpiece menu will appear. Select [Position] -> [Record]. The workpiece position 
will be recorded. 
 

3.3.4.5Resetting a workpiece position  

This section describes the procedure to reset a workpiece position. 

1Right-click the workpiece [ ] to be reset in the tree pane. 

2The workpiece menu will appear. Select Location] -> [Restore]. The previous position 
(recorded location) is restored. 

 

3.3.4.6Replacing a workpiece 

This section describes the procedure to replace a workpiece with another. 

1Right-click a workpiece icon [ ] in the tree pane. 

2A menu will be displayed. Select [Replace]. 
The file selection dialog box will appear. Select the workpiece file to be replaced, and press the 
[Open] button. 

 

3.3.4.7Renaming a workpiece 

This section describes the procedure to rename a workpiece. 

1Select a workpiece icon [ ] in the tree pane. 

2Then, left-click the icon again. 

 

3.3.4.8Saving a workpiece 

Workpieces added to the project can be saved. 
This section describes the procedure to save a workpiece. 
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1Right-click the target workpiece icon [ ] in the tree pane. 

2The workpiece menu will be displayed. Select [Save]. 

3The destination selection dialog box will appear. Select the name of the workpiece to be saved and the 

destination folder, and press the [Save] button. 

 

3.3.4.9Copying a Workpiece 

This section describes how to copy a workpiece. 
The workpiece can be selected for making the reproduction. 
  

1Right-click the target workpiece icon [ ] in the tree pane. 

2The workpiece menu will be displayed. Select [Edit] -> [Copy]. 

  

3.3.4.10Cutting a Workpiece 

This section describes how to cut a workpiece. 
The workpiece can be selected for moving. 

1Right-click the target workpiece icon [ ] in the tree pane. 

2The workpiece menu will be displayed. Select [Edit]->[Cut]. 

 

3.3.4.11 Pasting a Workpiece 

This section describes how to paste a workpiece. 
The cut or copied workpiece can be applied on the other object. 

1Perform the above workpiece (copy or cut).  

2Right-click the target object icon in the tree pane. 

3The workpiece menu will be displayed. Select [Edit] ->[Paste].  

3.3.5Obstacle 

This section describes the installation method of obstacles. 

3.3.5.1Adding an obstacle 

This section describes the procedure to add an obstacle. 

1In the tree pane, right-click the project icon [ ]. 

2The project menu will appear. Select [Add] -> [Environment] -> [Obstacle]. 
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3The file selection dialog opens. Select the target file, and press the [Open] button. 

 
The obstacle icon [ ] is added in the tree pane on the left side of the screen, and a model of the 
added obstacle is displayed in the central view. 

 

3.3.5.2Changing an obstacle position 

This section describes the procedure to change the position of an obstacle. 

1Double-left-click the added obstacle icon [ ] in the tree pane. 

2The position change dialog box will appear. Set each coordinate value by manually entering them or 

with the slide bar. 

3Press the [Apply] button to reflect the changed values, and press the [Close] button to close the 

dialog box. 

 

 The reposition dialog box can also be displayed by double-clicking the obstacle model in the 
view pane, or by selecting [Position] -> [Assigned Position] from the menu of the obstacle 

instead of double-left-clicking the obstacle icon. 

 

3.3.5.3Deleting an obstacle 

This section describes the procedure to delete an obstacle. 

1Right-click the obstacle to be deleted. 

2A menu will appear. Select [Delete]. 

 

3.3.5.4Recording an obstacle position 

This section describes the procedure to record an obstacle position. 

1Right-click the obstacle [ ] to be recorded in the tree pane. 

2A menu will appear. Select [Position] -> [Record]. The obstacle position will be recorded. 

 

3.3.5.5Resetting an obstacle position 

This section describes the procedure to reset an obstacle position. 

1Right-click the obstacle [ ] to be reset in the tree pane. 

2A menu will appear. Select [Position] -> [Restore]. The previous position (recorded location) is 

restored. 
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3.3.5.6Replacing an obstacle 

This section describes the procedure to replace an obstacle with another. 

1Right-click an obstacle icon [ ] in the tree pane. 

2The obstacle menu will be displayed. Select [Replace]. 

3The file selection dialog box will appear. Select the obstacle file to be replaced, and press the [Open] 

button. 

 

3.3.5.7Renaming an obstacle 

This section describes the procedure to rename an obstacle. 

1Select an obstacle icon [ ] in the tree pane. 

2Then, left-click the icon again. 

 
 
 

3.3.5.8Saving an obstacle 

This section describes the procedure to save an obstacle. 

1Right-click the target obstacle icon [ ] in the tree pane. 

2The obstacle menu will be displayed. Select [Save]. 

3The destination selection dialog box will appear. Select the name of the obstacle to be saved and the 

destination folder, and press the [Save] button. 

 
 

3.3.5.9Copying an Obstacle 

This section describes how to copy an obstacle. 
The obstacle can be selected for making the reproduction. 
  
Right-click the target obstacle icon [ ] in the tree pane. 
The obstacle menu will be displayed. Select [Edit] -> [Copy]. 

 

3.3.5.10Cutting an Obstacle 

This section describes how to cut an obstacle. 
The obstacle can be selected for moving. 

1Right-click the target obstacle icon [ ] in the tree pane. 
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2The obstacle menu will be displayed. Select [Edit] -> [Cut]. 

 

3.3.5.11Pasting an Obstacle 

This section describes how to paste an obstacle. 
The cut or copied obstacle can be applied on the other object. 

1Perform the above obstacle (copy or cut). 

2Right-click the target object icon in the tree pane 

3The obstacle menu will be displayed. Select [Edit]->[Paste] 

3.3.6Teaching Point 

The teaching point is the coordinate serving as a reference of the tool end when the robot is 
operated. 
This section describes the methods for adding teaching points and moving coordinates. 
The procedure to start the teach mode is as follows. 
 

3.3.6.1Specifying values to add a teaching point 

This section describes the procedure to specify values to add a teaching point 

1In the tree pane, right-click the project icon [ ]. 

2The project menu is displayed. Select [Add] -> [Point] -> [Assigned position]. 

The reposition dialog box opens. Manually enter or use the slide bar to set each coordinate value. 
Press the [Apply] button to reflect the settings. Then, press the [Close] button to close the dialog 
box. 

 

 

 

Showing the origin Hiding the origin 
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3.3.6.2Adding a teaching point to the current values 

This section describes the procedure to add a teaching point at the current values located at the tool 
(arm) end. 

1In the tree pane, right-click the project icon [ ]. 

2The project menu is displayed. Select [Add] -> [Point] -> [Current Position]. 

 
The teaching point will be added to the tool end (or the end of the robot arm when no tool is 

attached). 

 

 Assuming that the robot has been added and the teach mode is selected. 

 
 

3.3.6.3Repositioning a teaching point 

This section describes the procedure to change the position of a teaching point. 
 
Double-left-click the added teaching point icon [ ] in the tree pane. 
The position change dialog box will appear. Set each coordinate value by manually entering them 
or with the slide bar. 
Press the [Apply] button to reflect the changed values, and press the [Close] button to close the 
dialog box 
 
The reposition dialog box can also be displayed by double-clicking the teaching point in the view 
pane, or by selecting [Position] -> [Assigned Position] from the menu of the teaching point instead 
of double-left-clicking the teaching pointエラー! ブックマークが定義されていません。 icon. 

 

3.3.6.4Recording the position of a teaching point 

This section describes the procedure to record the position of a teaching point. 

1In the tree pane, select the teaching point to be recorded. 

2Right-click to display a menu, and select [Position] -> [Record]. The position of the teaching point is 

recorded. 

 

3.3.6.5Resetting the position of a teaching point 

This section describes the procedure to reset the position of a teaching point. 

1In the tree pane, select the teaching point to be reset. 

2Right-click to display a menu, and select [Position] -> [Restore].  

The original position (recorded location) is restored. 
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3.3.6.6Showing/Hiding a teaching point 

This section describes the procedure to switch the display of a teaching point. 

1In the tree pane, right-click the target teaching point. 

2A menu is displayed. Click on [View]. 

3The check mark [ ] indicates that the teaching point is being displayed. 

 

3.3.6.7Deleting a teaching point 

This section describes the procedure to add a teaching point. 

1Select the teaching point to be deleted. 

2Right-click to display a menu, and select Delete. 

 

3.3.6.8Copying a teaching point 

This section describes how to copy a teaching point. 
The teaching point can be selected for making the reproduction. 

1 Right-click the target teaching point icon [ ] in the tree pane. 

2 The teaching point menu will be displayed. Select [Edit] -> [Copy]. 

 

3.3.6.9Cutting a teaching point 

This section describes how to cut a teaching point. 
The teaching point can be selected for moving. 

1Right-click the target teaching point icon [ ] in the tree pane. 

2The teaching point menu will be displayed. Select [Edit] -> [Cut]. 

 

3.3.6.10Pasting a teaching point 

This section describes how to paste a teaching point. 
The cut or copied teaching point can be applied on the other object. 

1Perform the above teaching point (copy or cut). 

2Right-click the target object icon in the tree pane. 

3The teaching point menu will be displayed. Select [Edit]->[Paste]. 
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3.3.6.11Comment setting of teaching point 

Characters displayed near the teaching point can be edited, and their format can be changed. 
Each function of the comment menu of the teaching point is described below. 
[Show Model] ......The display setting of the comment is changed. Default setting is to display the 
comment. 
[Position ...] ......The display position of the comment is changed. 
[Color ...] ......The color of the comment is changed. Default color is black. 
[Size ...] ......The size of the comment is changed. Default is 10. 
[Comment ...] ......The character of the comment is changed. Default is the same name as teaching 
point node. 

 
 

3.3.7Tool 

This section describes how to handle tools. 
 

3.3.7.1Adding a tool 

This section describes the procedure to add a tool to the robot. 

1In the tree pane, select [Tool] -> [Load] from the robot menu. 

2The file selection dialog box will appear. Select the target file, and press the [Open] button. 

 
 

3.3.7.2Attaching a tool 

This section describes the procedure to attach the tool read in the robot. 

1In the tree pane, select [Tool] -> [Attach] from the robot menu. 

2The tool selection dialog box is displayed. The read tool is displayed in the list box. 
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1Select the tool to attach from the list box, and press [OK] button. The tool attached before change is 

released, and the selected tool is attached. 

 

3.3.8Other Components 

This section describes the method for arranging other components. 
 

3.3.8.1Group 

The group is a component to group objects into a hierarchy. 
This section describes the procedure to add a group. 

1Select [Add] -> [Group] from the menu. 

 
User operations to attach/detach, copy, cut, paste and delete a group are equal to those of 
workpieces and obstacles. 
*The operations of attach/detach, copy, cut, paste, and delete are the same operations as 
work/obstruction. 

 

3.3.9Track Line 

This section describes the Track line of the end of the robot arm. 

3.3.9.1Track Line Setting 

This section describes the procedure to display the Track line. 
 
Right-click the [Track line] item located in the robot tree, and check that a check mark is placed at 
[Show Track Line]. In this case, the Track line is drawn when the end of the robot arm moves. 
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The functions of the Track line are described below. 
[Color...] : Usable to change the color of the Track line. 
[Type] :you can select dots or lines. 
[Size] : you can specify the size of dot when selecting dots. 
[Clear Data] : Usable to delete the Track line data. 
After the Track line data are deleted, a new Track line is drawn when the robot arm has been 
moved. 
[Delete] : Usable to delete selected teaching points when there are multiple Track line items. 
 
As functions other than above, Track line can be renamed in the same way as applied to the robot, 
or repositioned by double-clicking it. 

 

3.3.10Loading the other format 

K-ROSET Hisui edition is operated with data in the STL format, and can read data in IGES 
format. 
K-ROSET Hisui starts as different application from K-ROSET. 
Inserting an appropriate USB is necessary for execution. 

 

3.3.11Batch Operation 

Operation can be applied to multiple objects at once. Batch operation is described in this section. 
This operation is effective in recording/restoring positions and showing/hiding origins and 
showing/hiding. 

 

3.3.11.1Recording or resetting positions by batch operation 

This section describes the procedure to record positions by batch operation. 

1In the tree pane, right-click the project icon [ ]. 

2A menu will be displayed. Select [Batch Operation] -> [Position] -> [Record]. 

3A list is displayed. Select the target items. 

(For Environmental Object, additionally select either Workpiece or Obstacle.) 
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The procedure to reset positions by batch operation is as follows: 
 
In the tree pane, right-click the project icon [ ]. 
A menu will be displayed. Select [Batch Operation] -> [Position] -> [Restore]. 
A list is displayed. Select the target items. 
(For Environmental Object, additionally select either Workpiece or Obstacle.) 

 

3.3.11.2Switching the display of objects/origins by batch 

operation 

This section describes the procedure to show or hide objects or origins by batch operation. 
 

3.3.11.3Switching show/hide display of objects and origins 

by batch operation 

This section describes the procedure to show/hide objects and origins by batch operation. 

1In the tree pane, right-click the project icon [ ]. 

2A menu will appear. Select [Batch Operation] -> [View Origin] or [Batch Operation] -> 
[View]. 

3A list will be displayed. Select the target items for batch operation. 
(For Environmental Object, additionally select either Workpiece or Obstacle.) 

 

3.3.12Transformed value 

 

3.3.12.1Modifying a Base trans 

 

The method for changing the base trans perform the following procedure. 
 

1Select the robot from tree pane. 

2A menu will be displayed. Select [Base Trans] -> [Setting]. 

3The Base Trans dialog box will appear. Input the value in the space. 

4Close the dialog by clicking the button of [Apply]. 
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3.3.12.2Show/hide a Base trans 

The method to show or hide the base trans perform the following procedure. 

1Select the robot from tree pane. 

2A menu will be displayed. Select [Base Trans] -> [Show]. 

 

 The check mark [ ] indicates the state of showing. 

 

3.3.12.3Modifying a Tool trans 

The method for changing the tool trans perform the following procedure. 

1Select the tool from tree pane. 

2A menu will be displayed. Select [Tool Trans] -> [Setting]. 

3The Tool Trans dialog box will appear. Input the value in the space. 

4Close the dialog by clicking the button of [Apply]. 
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3.3.12.4Show/hide a Tool trans 

The method to show or hide the tool trans perform the following procedure. 

1Select the robot from tree pane. 

2A menu will be displayed. Select [Tool Trans] -> [Show]. 

 
The check mark [ ] indicates the state of showing. 
 

3.3.13Project Setting  

Right-click on the project name of the layout tab to show the menu, and then select [Setting]. 
The project setting is described. 

 

 
 

★ Operation mode 

Standard mode and editor mode are switched. The applied function can be used in the editor mode. 
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 * Refer to 3.6. for the editor mode. 

 

★ Show Position dialog 

The position change dialog is automatically opened when a model is added. 
 

★ Show origin of model when loaded 

The model origin is displayed when a model is added and a project is read. 
[Pasting operation included] ...This setting is applied for [Edit] - [Paste] operation. 
 

★ Animation robot when pushed key 

When selection of the teaching point is switched in tree of the layout tab with the up and down 
keys on the keyboard, the setting for changing robot posture on a view is carried out. 
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MEMO 
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3.4Teach Panel 

This section describes the Teach Panel panel. 

 

 
 



 

54 

3.4.1 Option 

The setting at the current robot is carried out. 

★ Adding teach point 

[Add Point by Click] 
Enabled by placing a check mark in [Add point by click]. When click teach point is enabled, a 
teach point is added by clicking the surface of the environment on the view. 
 
 
 [Add Point at Current Position] 
Add a teach point to the tip of arm. The teaching point is added as an object under the robot in the 
tree. 

 *When the direction of the added teaching point is not specified at teaching point posture 
setting, the direction of the added teaching point is the direction of the tool tip. For the teaching 

point posture setting, refer to teaching point posture setting of plug-in application. 

 

★ Velocity 

Magnification of the displacement is changed. 
Press the button to change the display of the gauge and increase the displacement 
single/double/triple time(s). 

 

★ Displacement 

The displacement of the posture change in each travel mode is set. 
The displacement is changed by spin control or entering a numeric value. 
Initial value of the displacement is [rotation: angle of 5 degrees, direct motion: 10mm]. 
 

 * When the hand guide is displayed, the tool coordinate cannot be selected. 

 

★ Posture 

[RIGHTY] <-->[LEFTY] 
Robot posture is changed so that the posture looks like the right arm (RIGHTY) or left arm 
(LEFTY) of a human. 
 
[ABOVE] <--> [BELOW] 
Robot posture is changed so that the posture looks like the right elbow located above (ABOVE) or 
below (BELOW) of a human. 
 
[UWRIST] <--> [DWRIST] 
Robot posture is changed so that the angle of the 5 axis of the robot is positive (UWRIST) or 
negative (DWRIST). 

 

★ Limitation of axis values 

Posture limit of the robot in teaching is disabled. 
Place a check mark in [Disable axis value limitation of controller] to disable. 



 

55 

 

★ Home setting 

Current robot postures, up to 2 postures, can be recorded so that the robot can restore its posture to 
the recorded ones later. 
[Current value] ...... Posture of the robot in the combo box is input. 
[Clear] ...... The entered numeric value is cleared. 
[Application] ...... Posture of the entered numeric value is applied to the robot. 

 

  
  

3.4.2Robot control 

Robot names and robot types are displayed and posture checking and teaching are carried out. 
The robot marked with a diamond shape on the right of the robot name is a current target robot. 
Operation on this panel during controller running is invalid. 
 

 
 
 

★ Teaching Operation 

Posture change is selected in each travel mode. 
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Select from each axis, base coordinate, tool coordinate, world coordinate, and work coordinate 
with the radio button. 
 

★ Direct Teaching 

Robot posture is changed from the operation on the view. Place a check mark in [Hand guide 
display] to enable. 
 

★ Posture Change 

Posture of the robot is changed with each operation. 
Spin-box [ ] 
Increase/decrease the value of the variables on the left by clicking Spin-box [ ] to change the 
robot posture. 
 
Bar-control 
Posture of the robot is changed at each axis by clicking the bar. 
Blue:30 to 100%, Yellow:10 to 30%, Red:0 to 10% 

 
 
Value Input 
Posture of the robot is changed by direct input of the axis values and converted values. After input 
of the values, the values are applied by pressing [Enter]. 
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3.5Program Table 

This section describes the program table. 
 
 

3.5.1Creating a program 

Creating a program and adding/editing program instructions on K-ROSET. 
 

 
 

The program table is used to create programs using the AS language, add I/O instructions, and 
import programs created with PC-ROSET. 

 

3.5.1.1Adding a program 

This section describes how to add a program to K-ROSET. 

1In the extended application pane, choose the [ ] icon to display the [ProgramTable] 
screen. 

2From the ControllerName menu (displayed by right-clicking the area indicated by [C01] 
below), choose the [Add] -> [Program]. 
 
After the menu is selected, a program is newly created on the program table. 

 * The program can be renamed from this menu item. 

 
Then, the method of adding program instructions to a program is described. 
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This section describes how to add each program instruction into the program. 

 
 

3.5.1.2Changing a program name 

1Input box become available state by clicking it. Change the name by typing keys.  

 

 

3.5.1.3Coping/ Cutting a program 

1Select [Edit] -> [Copy] or [Edit] -> [Paste] from the program menu.  
 
 

3.5.1.4Pasting a program 

1In the state of the coping or cutting a program, select [Edit] -> [Paste] from the program 
menu. 
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3.5.1.5Deleting a program 

Select [Delete] from the program menu. 
 

3.5.2Adding program instructions 

 

3.5.2.1Adding program instructions 

 
1. Select any program instruction after selecting [Add]-[Program Step] from program name menu. 

 
2. The selected program instruction will be added to the program. 
Values in the instruction and programming language can be changed from this menu item. 
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 * For the detailed description and details of each command, refer to "AS Language Practical 

Guide." 

 
Add one from a teaching point into the program. 
By dragging teaching points which were added to the tree and dropping them on a program on the 
program table, a programming instruction by which control can move to the specified teaching 
point can be added. 

 

 
For the instructions which can be added by dragging and dropping a teaching point, two types are 
usable: joints interpolation moving and linear interpolation moving. 
 
To switch the type of the instruction added, right-click ROOT on the program table to display the 
Root menu, and select [Settings...]. Then, in the [Program table settings] screen, make a new 
setting at [Drag and Drop setting] -> [Operational instruction]. 
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The program instructions which can be added via this menu item are as follows. 
Moving instruction Joints interpolation moving (JMOVE) 

Linear interpolation moving (LMOVE) 
Linear interpolation moving (wrist joint: even-angle interpolation) 
(HMOVE) 
Arc interpolation moving (middle/end points of the arc) 
(C1MOVE) 
Arc interpolation moving 2 (middle/end points of the arc) 
(C2MOVE) 

Spray instruction Turning spray ON/OFF (SPRAY) 
Turning spray-preceding ON/OFF (distance/time) (DRE_SPRAY) 
Turning spray-delaying ON/OFF (distance/time) (DLY_SPRAY) 

I/O instruction Signal input waiting （DIN_WAIT） 
External output signal (DOUT) 
Specification of signal state after specified time (DLYSIG) 
Mutual waiting (MUTUAL_WAIT)〔Option〕 

Speed instruction Specification of joint speed of air-cut (AIRCUT_JSPEED) 
Specification of end speed of air-cut (AIRCUT_SPEED) 
Specification of spraying joint speed (SPRAY_JSPEED) 
Specification of spraying end speed (SPRAY_SPEED) 
Specification of moving time (second) (MOVING_TIME) 
Specification of regeneration speed ratio (PLAYBACK_RATE) 

Spray-preceding/delaying 
instruction 

High Voltage (HIGH VOLTAGE) 
Shaping/pattern air (SHAPING/PATTERN AIR) 
Air motor/Atomizing air (AIR MOTOR/ATOMIZING AIR) 
Flow rate (FLOW RATE) 
Push_thinner (PUSH_THINNER) 
Flushing start (FLUSHING START) 
Flow tate_ratio (FLOW RATE_RATIO) 
Pattern rate (SHAPING/PATTERN AEI_RATIO) 
Air motor/atomizing air_ratio(AIR MOTOR/ATOMIZING 
AIR_TATIO) 
High voltage ratio (HIGH_VOLTAGE RATIO) 

Conveyor/gun instruction 
〔Option〕 

Start conveyor synchronization (CVSTART) 
End conveyor synchronization (CVEND) 
Waiting for conveyor (CVWAIT) 
Gun selection (GUN) 

Sensor instruction 
〔Option〕 

Start/end door closure correcting section 
(DOOR_COMPENSATION) 
Start door detection (START DOOR SENSE) 
Detect door closure position (GET CLOSE DOOR POSITION) 
Move door closure position (MOVE CLOSE DOOR POSITION) 

Smooth/time instruction Acceleration/deceleration (ACCEL) 
Smooth range (SMOOTH_RANGE) 
Waiting timer (TIMER_WAIT) 

Call-up/databank Call up databank (CALL DATA BANK) 
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instruction Call up program (CALL PROGRAM) 
Branch instruction (1/2) Program switching (PGM_SELECT) 

(unconditional) label jump (GOTO) 
(True) label jump (TRUE JUMP) 
(False) label jump (FALSE JUMP) 
Label (itself) (LABEL) 

Branch instruction (2/2) Large comparison (GREATER COUNT) 
Small comparison (LESS COUNT) 
Large equality comparison (GREA TER/EQUAL COUNT) 
Small equality comparison (LESS/EQUAL COUNT) 
Substitute (LOAD) 
Add (ADD) 
Subtract (SUBTRACT) 
Equality comparison (EQUAL COUNT) 
Inequality comparison (NOT EQUAL COUNT) 
Input comparison (DIN_JUMP) 

Table instruction 
〔〕Option〕 

Start/end table synchronization (TABLE TRACK ON) 
Wait for table rotation (TABLE TRACK OFF)  
Set table rotational speed (TABLE WAIT))  
Execute conditional table rotation (TABLE SPINMOVE) 
End table rotation (halfway) (TABLE SPINSTOP) 
Execute table rotation (TABLE ROTATION) 

Other Comment 
* Refer to AS language instruction manual for the detailed description method of each instruction 
and contents. 

 

3.5.2.2Editing Program Instructions 

This chapter describes how to edit program instructions. 
 
Editing/deleting a program instruction 
For the editing methods of program instructions, the following four are typical. 
 

★ Edit on the program table. 

On the program table, the content of each program instruction can be edited directly. In addition, 
from the menu displayed by right-clicking an instruction, the instruction can be deleted, copied, 
cut, or pasted. It is also possible to move each program instruction by selecting the line number 
section. 
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3.5.3Loading/Saving in programs 

3.5.3.1Loading in programs 

The procedure of loading in created program files is as follows. 

1Add a robot to the tree pane. 

2From the controller menu of the program table, choose [Add] -> [Program] -> [File (.pg)]. 

3The program file choice dialog will be displayed. Select the program files that you wish to 
read in. 

 
 

3.5.3.2Saving a program 

The procedure of saving the program being created currently is as follows. 
 
Add a robot to the tree pane. 

1From the controller menu of the program table, choose [Add] -> [Program]. 

2From the program menu of the program table, choose [Save file]. 

3A dialog to save program files will be displayed. Select the destination folder and the 
program file name to be saved, and press the [Save] button. 

 
The name of the program saved is partially restricted. For details, confirm the section of restriction 
in Chapter 8. 

 

3.5.4Execution of a program 

 

★ All Step execution 

By using PC-AS, simulation is performed. 
 

★ Simplified execution 

Before conducting a detailed simulation, it is possible to execute instructions in a simplified 
manner to grasp the program operation roughly. 
 
The procedure of simplified execution is as follows. 
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3.5.5Other Functions 

3.5.5.1Variables 

It is possible to store values in variables on a program and perform programming using them. 
Values of a teaching point, string, or real number can be stored in variables. Hereinafter how to 
create variables are described. 
 
Values in the instruction and programming language can be changed from this menu item. 

 

 * For the detailed description and details of each command, refer to "AS Language Practical 

Guide." 

    
 

3.5.5.2Creating a teaching point variable 

It is possible to store teaching points in variables and use them on programs. 
To do so, this section describes the creation of a teaching point variable used when a program is 
created. 
Note that the variable is handled differently from the teaching point on the object tree. 

1Select [Add]-[Point] from program name menu. 
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2Select [Trans] or [Joint]  
Joint : Input each axes value. 

  
Trans : Input the coordinates from the base trans to the tool trans 

  

 

4Select [Coordinate] or [Current Value]. 
Coordinate : A input box is added. They are all zero values. Specify the joint degree. 
Current Value : A input box is added. They are values of current coordinate. 

 

3.5.5.3Creating a string variable 

The procedure of creating a string variable is described. 

1Select [Add]-[String Value] from program name menu. 

2Input character string 

   

 

3.5.5.4Creating a real number variable  

The procedure of creating a real variable is described. 

 
 

1Select [Add]-[Real Value] from program name menu. 

2Input the value or click the spin button. 

   

 

3.5.6Program Table Settings 

The procedure of setting program table is described. 
Select [Application Setting] from the root menu of the program table to display. 
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★ Tree View Setting 

Language displayed in the tree can be changed. 
Set Common for all controllers and Separate for the specified controller for the language setting. 

 

★ Drag and Drop Setting 

Motion command/teach point converted for drag and drop can be changed. 
 

★ Pasting Order Setting 

When simulation is executed, execution steps can be highlighted. 
Place a check mark in "Enable" to select and display the applicable column. 
Place a check mark in "Activate" to move Focus to the applicable column. 
Place a check mark in "Enabled when executed from other application" to display with highlighted 
even when executed from terminal and controller tab. 
 

★ Program step highlight setting 

When program step is coped several times and they were pasted, the order to add to a program can 
be changed.  
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4  Plug-in application 
This section describes extended applications. 
Extended applications are the extended functions which are usable in addition to the standard 
K-ROSET functions. Users are allowed to create extended applications by themselves in addition to 
accessory applications. 
 
Hereinafter, the menu for adding or deleting extended applications is described. 

 

 
 

In this screen, it is possible to switch the state of extended applications between valid/invalid, set/reset 
the function of making the extended application window floating, and check the description and version 
of the extended applications. 
To reflect the extended applications which have been disabled and the setting/resetting of the floating 
function, K-ROSET must be restarted. 
 
Files not recognized as extended applications are not displayed. In addition, files having the same name 
as that found in the System tab are grayed out, so that they cannot be loaded. 
To unload an extended application, uncheck the item and start up this software again. The guideline for 
users to create extended applications by themselves is found in a separate reference document. 
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Plug-Ins applications 
Application name Descriptions 
Plug-in Menu Show menu of plug-ins. 
Collision Check Change configurations of collision check 
Collision Log Execute multiple robots at the same time 
Undo Relocation Show operation history of relocation and undo. 

Wizard to Set External Axis Set a external axis by the wizard 
Cycle Time Show a cycle time table. 
Log Show error log information. 
Orientation of Points Set an orientation of points 
Terminal Show terminal of the controllers 
Time Line Move robots according to trajectory files. 
Installable Position Analysis Analyze installable position of a robot. 
I/O Signal connections Connect I/O signals between controllers. 
I/O Monitor Show and set I/O status of controllers. 
Action This function can draw Pint and track line to a 

work- piece or move the model with robot signal. 
Paint Edit instructions for Explosion-proof paint 

application. 
Option Change the settings of K-ROSET. 
Create Painting Program (Copy) Create a painting program copying selected points. 
Create Painting Program (3 Points) Create a painting program using 3 points on a plane. 
Paint Simulation Show paint path and paint effect (cone). 
Draw Track Line Draw track lines when a robot moves. 
Teach Panel Move robots manually. 
Controller Operate a controller. 
Automatic Start of Controller Start a controller when a robot is added, 
Gun Wizard for painting Create painting guns. 
Handling Clamp Change the clamp I/O signal settings. 
Handling Simulation Clamp workpieces according to the signal status. 
Simple Teach Move a axis of a selected robot 
View operation plug-ins Applications for a viewpoint change function and a 

distance measurement are available. 
Draw Teach Point Draw teach points when a robot moves 
Simple Shape Generator Create a simple model on the view 
Program Conversion Convert the program with shift or mirror method 
Record Video Record the view on the simulation 
Signal Graph Display Show a graph of I/O signal. 
Power Consumption Estimate consuming power of a robot. 
Start Page*) Displayed next to layout tab. Read a project, save a  

project, and recently used shortcut can be selected. 
Qiuck builder Support project creation. A project model can be 

created with dialogue format. 
Arc Simulation Display welding line and change settings of touch 

sensing. This plug-in is dedicated for arc welding. 
Spot Welding Setting Display servo gun welding tracks and display / 

change settings of servo welding gun. This plug-in 
is dedicated for spot welding gun. 
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4.1Simulation (including conveyor) 

Several robots on carrying out a project can be simulated concurrently. 
In addition, the outline of the procedure of the conveyor setting is described below. 
 

1With one or more robots in a project, select [Simulation] of the [Plug-in] menu on the upper 
side of the screen. 

 

 
 

2After the selection, a list of the robots in the project is displayed. 
 
When displaying without setting, a program in the program table is selected by default. 
The program created in the program table is displayed as "Program in editing" in  [PG name]. 
Select the entry field of PG name to select [Open ...] button, and press [Open ...] button to display a 
dialog.  
Then select the program file to execute. 
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3After selecting the program, press the button [Apply] to transfer the program to the 
controller. 

4Carry out the operations of procedure 2. and 3. to all the robots of concurrent execution. 

5Click [Repeat] button to start the concurrent execution of the simulation. 
Press the [Stop] button to stop the concurrent execution. 
Press [Temporary Stop] button to stop the concurrent execution temporarily. 
To stop simultaneous execution, press the [Stop] button. 
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4.2Controller 

This section describes Controller. 
Controller is used to load a program created by the program table, or start/play/stop the terminal.  

 *It is necessary to start Virtual Robot Controller (PC-AS) when controller tab of robot name is disable. 

Refer to Controller settings. 

 
 

 

 
[TEACH/REPEAT (Teach/Repeat switch) ]……Teach mode/Repeat mode is switched by clicking 
mouse. 
[Motor(Motor Power button/lamp)]……Motor power is on by clicking mouse. 
[Cycle (Cycle Start button/lamp)]……Lamp is lighted up when simulating in the state of repeat mode. 
[Error(Error lamp)]……Lamp is lighted up when errors occur. 
[Reset (Error Reset button)]……Clicking this button in the state of error, it can be awoken. However, 
the error continued can’t be awoken. 
[EMG]……Clicking this button in emergency, Robot stops the motion. 
 
[Show Monitor…]……Status monitor for displaying value of joint value, step information is shown. 

 

 
[Load…]……Program is transported to Virtual Robot Controller(PC-AS). 
[Execute]……Run the program. 
[Synchronize…]…Parameters is synchronized or disposed between PC-AS and Layout. 
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It is possible to synchronize the settings made on the PC-AS side with those of the controller on the 
project side, and vice versa to reset the settings on the PC-AS side. 
 
A procedure to synchronize PC-AS with the project’s controller is as follows. 
 
A procedure to synchronize the project’s controller with PC-AS is as follows. 
 
[Show MFP/Hide MFP]……Showing/hiding the Virtual Teach Pendant. 
 

 
 

In Quick Settings Tab, the setting of the screen rendering in simulation is carried out. 
 

 
 

[Check interference] ...... Sets whether the point interfered during simulation is displayed. 
[Display interfering surface] ...... Displays the detailed interfering part when interfering. The interfered 
model itself highlights when unchecked. 
[Stop a robot when interference occurs] ...... Stops the robot at the interfering position during 
simulation. 
[Output trace file] ...... Sets whether the trace file is output after simulation exits. 
[Animate a robot in teaching mode] ...... When a check mark is placed, a robot can be stepped 
forward/backward with a virtual teach pendant by switching to a teaching mode. 
[Highlight program step] ...... When a check mark is placed, the program step of the program screen can 
be highlighted in simulation motion according to the running step. 
 

 * A cycle time is displayed with placing this check mark. 
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[Separate] ...... Sets whether view and synchronization is carried out to robots separately. 
 

4.2.1Repeating Program 

This section describes the method to replay an AS program. 

1Select the Controller at the bottom of the screen. 

2Select the tab of a robot name.  

3Enter the REPEAT mode[ ](right side).  

4Turn ON the motor. [ ](light a lamp).  

5Press the [Load…] button. 

6A dialog to choose a file will be opened. Select a program file that you wish to execute. 

7Programs in the program file are listed. Select the target program. 

8Press the [ ] button. 

 
To repeat the AS programs for multiple robots simultaneously, execute extended applications 
simultaneously. 
The turbo mode is usable as an advanced setting. Using this mode makes it possible to execute 
simulation at a high speed. 
The procedure of setting the turbo mode is described below. 
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 Memo 
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4.3I/O Monitor 

This section describes IO Monitor. 
 

 
In IO Monitor, input/output signal of each robot can be displayed and controlled. 

 
Display 
Input signal [1-256], output signal [1001-10256] and internal signal [2001-2512] can be switched by 
clicking spin-control. 
 

★ Control 

On/Off of signal can be switched by clicking each signal box. 

 * Moving mouse cursor to a signal box, signal number is popped up. 

 * There are previously-used signals as follow. 

Green: Signal depended application (Robot controller). 
Blue: Signal defined as common dedicated output signal. 
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MEMO 
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4.4Terminal 

This section describes Terminal. 
 
In Terminal tab, AS commands can be executed. 

 * For details of AS Language, refer to "AS Language Practical Guide." 

 

 
 

★ Current Folder Setting 

[Folder Name] ……Target path for saving/loading of the file used in terminal is set. 
[Display Explore..] ……Click to display Explore of the set path. 
 

★ Log Settings 

[Output Log] ……Data input in terminal is output. Place a check mark to output. 
[File and Folder Name]……Target path and file name for outputting a terminal log is set. 
[Display Explore…] ……Click to display Explore of the set path. Default of file name is date of 
operation. 
 

 * Path is saved when the project is saved. When the project is read at other terminal, a folder is 

created at the specified folder. 
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4.5Virtual Teach Pendant (VTP) 

This section describes Virtual Teach Pendant. 
On Virtual Teach Pendant, advanced setting and monitoring motion similar to the actual Teach Pendant 
is available. It is operated by click operation of the mouse. 
 

 Operation in Teach mode needs switching to teach mode as well as enabling robot animation. 

 (For details, refer to the chapter of option settings.) 

 Exceptionally, the robot is operated using the VTP interface panel in Repeat mode. 

 

 For the detail of operation of Teach Pendant, refer to robot operation manual. 

 
Operation Screen 
Hard key 
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★ Position Change of Hard Key 

The position of the hard key can be changed by selecting [Position] from right-click menu. 
 

★ PC-AS Link Exit 

Click [Close] button on the Virtual Teach Pendant. 
Select [Exit] from right-click menu of the hard key. 
 

★ Show and Hide of Pendant 

Click [Minimize] button on Virtual Teach Pendant.(Displayed in toolbar） 
Click [Hide Pendant] of the controller. (Undisplayed in toolbar) 
 

★ Controller 

The controller has a function similar to the controller panel. (*Refer to Controller section.) 
 

★ Hard key display switching 

The display of the hard key can be changed to hidden/simplified/normal. 
 

★ Changing size of operation screen 

The size of the operation screen can be changed at 3 stages: small, medium, and large. 
Refer to "5.5.2 Option setting" for a changing method. 

 

4.6Virtual Robot Controller (PC-AS) 

This section describes Virtual robot Controller. 
The virtual robot controller is used to execute actual AS on software for simulation. 
The virtual robot controller consists of virtual controller module, and operates per robot. 
Examples of modules (asproc.exe, Panel.exe, PcAs.exe, user_as.exe, user_tp.exe) 
 

 * Confirmation by the firewall is displayed in the initial start.. Select [Unblock]. 
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4.7Log 

This section describes the log output window. 
 

 
In the log output window, logs of operations and occurred errors are output. 
The output log is saved in the following folder when the option setting is default: 
<(system folder) Ylogs> 

 * The destination is changed by optional setting. 

For the option setting, refer to option setting of the plug-in application. 
In addition, abnormality or warning can be displayed according to levels in the option. 
 

★ Clear 

Current display is cleared. 
 

★ Keyword 

Lists can be filtered. 
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 Memo 
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4.8Cycle Time 

This section describes Cycle Time. 
 
Cycle Time displays a saved track line file. 

 
 

There are two methods to display Cycle Time. 
 

★ Outputting a trajectory file 

To output a trajectory file, confirm that the “Display cycle time” setting of extended application is valid, 
and select Controller at the top of the screen. Check “Output trajectory file,” and press the [Apply] 
button. 
 

★ Open trajectory files 

Select [File] -> [Open] from the menu, and choose a trajectory file. The cycle time of the chosen 
trajectory file will appear. In addition, when a program has already been executed, cycle time will be 
displayed automatically. 
 

★ Export Csv File 

By selecting [File] -> [Output a Csv file], the cycle time displayed in this screen can be saved in the 
CSV format. 
 
 

★ Display cycle time for each SPRAY No 

By pressing the [Display cycle time for each spray No.] button, cycle time will be grouped and 
displayed for each discharge No. 
 

4.8.1Show automatically 

When a program is executed, the cycle time screen will appear.  
 
Check [Setting] -> [Output Track Line File] in Controller. 
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A trajectory file will be output to the “My Document/MyKHILibraries/Projects/[Project name]/Traj” 
folder when the program has been normally ended or abnormally ended due to an error etc., then the 
cycle time screen will appear. 
 

 

4.8.2Show manually 

Start up from K-ROSET menu 

★ Read files 

Select [File] -> [Open] from the menu, and choose a trajectory file. The cycle time of the chosen 
trajectory file will appear. 
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4.9Collision Check 

On the interference pair check settings screen, it is possible to set up to display when models are 
interfering with each other on the view. 

 
 

To register a new interference pair, choose pairs of the models that you wish to register from the two 
trees on the left, and press the [Add] button. 
 
To delete a registered interference pair, choose the pairs that you wish to delete from the interference 
pair registration list, and press the [Delete] button. 
 
In addition, it is possible to switch the state of interference check between valid/invalid for each project 
or model. 
 
When interference occurs between the members of an interference pair which was registered during 
simulation, only when the interference plane is set to “Show,” the information on the target pair is 
output to the interference log. The content of the interference log is cleared by pressing the [Clear log 
data] button. 
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4.10I/O Signal Connections  

It is possible to connect the output signal of a robot (OX) with the input signal of another robot (WX). 

 
 

To set up interlock, select [Setting] -> [Plug-ins Setting] from the menu, and confirm that 
[InterlockControlGUI.dll] is effective. 
In the extended application menu in the right portion of the screen, select the [I/O Signal Connections] 
tab. Hereinafter, each item is described based on the screen above. 
 
[Robot] : Select a robot to which the output signal is connected. 
[OX(output)] : Enter an output/internal signal number.  
[WX(input)] : Enter an input/internal signal number.  
[Trigger] : The output condition of interlock can be selected from [Rising], [Falling], and [Through]. 
[Rising] : Output signal is output to the input signal when the former signal is turned ON. 
[Falling] : Output signal is output to the input signal when the former signal is turned OFF. 
[Through]: The change of the output signal is output to the input signal as it is. 
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[Delay]  : Specify a delay time elapsing from the change of the output signal to output to the input 
signal. 
[Pulse] : Specify a pulse width to make the input signal effective. 
 
♦ Settings 
[Open…] : Able to read in the interlock settings file (with extension .iolock) which was saved by 
pressing the [Save...] button. 
[Save...] : Able to output the interlock settings to a file to record them. The extension of the file saved 
is .iolock. 
[Check Sig] : Able to check the upper signal value of robots. 
 

 When a project is saved, the interlock settings are also saved automatically. Therefore, it is not 
necessary to save the interlock settings in another file except when they are diverted to some other 

project. 
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4.11Option 

On the Option window, each item regarding K-ROSET can be set up. 

 
 

Change the settings for each item, and press the [Apply] button. The change will be reflected to 
K-ROSET. 
Press the [Default] button, and press [Apply] button again. The setting of each item will return to the 
state when the system was installed. 
 
Hereinafter, this chapter describes the settings in each tab. 

 

4.11.1[Option Settings] -> [Language] 

 

In the language tab, the language displayed by all parts/components of K-ROSET can be set up. 
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The applicable languages are as follows: 
(“en-US” is set by default when the system is first started up.) 
- en-US (English - the United States of America) 
- ja-JP (Japanese - Japan) 

4.11.2[Option Settings] -> [Display] 

In the Display tab, various types of display on K-ROSET can be set up. 
 
 

4.11.2.1[Option Settings] -> [Display] -> [Highlighting Colors] 

Optional highlighting colors to select an entity on the view or tree can be set up. 

 
 

The highlighting color can be selected from the following four. 
- Color 1 / Color 2 / Color 3 / Color 4  
 

4.11.2.2Option Settings] -> [Display] -> [Display Style] 

The style of the entire K-ROSET and the size of the virtual teaching pendant can be set up. 

 
 

★ ♦Style 
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It is possible to select the screen style of the entire K-ROSET. 
 

★ Virtual teaching pendant size 

The size of a virtual teaching pendant can be selected from the three sizes of large, medium, and small. 
- Large (646 X512 pixels) 
- Medium (566 X452 pixels) 
- Small (486 X392 pixels) 

 
 

4.11.2.3[Option Settings] -> [Display] -> [Arrow] 

For the arrows which are displayed on the view such as a teaching point, base, tool, and gripper, the 
view of can be switched and the length and color properties can be set up. 
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★ Display 

It is possible to change the setting of view for each type of the arrow. 
 

★ Size 

It is possible to change the setting of length (thickness) for each type of arrow. 
 

★ Color 

It is possible to change the setting of color for each type of the arrow. 
 

4.11.2.4[Option Settings] -> [Display] -> [Ground Grid] 

For the grid displayed on the view, it is possible to switch show/hide of the view, and set up display 
range, size, and color. 
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★ Display 

It is possible to change the setting of view of the grid. 
 

★ Size 

It is possible to change the display range and size of the grid. 
 

★ Color 

It is possible to change the setting of color for each type of the arrow. 
 

4.11.2.5[Option Settings] -> [Display] -> [Track Line] 

For the trajectory lines displayed on the view, it is possible to switch show/hide of the view, and set up 
thickness, length, and color properties. 
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★ Display 

It is possible to change the setting of view of the trajectory. 
 

★ Color 

It is possible to change the setting of color of the trajectory 
 

★ Generate 

Generate Track Line when Track Line is Hidden. 
In the state of hiding the track line, it is always drown. 
Generate Track Line on a Work 
Track line on the work is generated. 
Minimum Line Segment (mm): Display is so coarse as to increase a value. 

 

4.11.3[Option Settings] -> [Project File] 

 
 

★ Save 

Putting a check mark in a check box of [Save Project when Couldn’t find Shape Data Files] allows 
project saving 
even when the model file displayed on the project does not exist; such as a disappeared data file for 
some causes  
during the project construction, or the moved file having been accessed via the shared drive or the 
network. 

 
Usually turned OFF. 

 

4.11.4[Option Settings] -> [Collision] 

On the Collision tab, it is possible to switch the display of the Collision state on the view, and the 
display of the results of the Collision check to be output to the log and so on. 
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★ Display 

Show Colliding Planes 
Displaying collision planes, color of only model planes is changed. 
 
Enable Collision Detection 
Parts collided is displayed. 
 

★ Log 

Number of lines of logs about collision is set. 
 

 

4.11.5[Option Settings] -> [System Log] 

On the log output tab, it is possible to set up execute/stop output K-ROSET’s operational log, the 
destination and name of the log file, and the level of the log. 
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★ Log 

Output and Display of log can be set. 
Un-checking [Accept the System Default Path], any path is selected for output. 
 

 It is not allowed to use prohibited characters for the output path and file name of the log. Unusable 
prohibited characters are as follows. 

¥  /  *  ?  “  <  > (all single-byte characters) 

 

★ Output Mode 

It is allowed to select a log level from the following seven levels. 
It is also possible to set up log level for each robot so that a log of a particular log level only is output. 
Level 1: System Error (serious error related to the entire system) 
Level 2: Module Caution (warning message of the entire system) 
Level 3: Module Result (operational results of the entire system) 
Level 4: Module Action (operational content of the entire system) 
Level 5: Func Caution (warning message issued for each function) 
Level 6: Func Result (operational results for each function) 
Level 7: Func Action (operational content for each function) 
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4.11.6 

[Option Settings] -> [Simulation] 

On the simulation tab, it is possible to set up the output of simulation results, change of simulation 
speed for each robot, synchronization with the view, and replay mode (for replaying a 
program/trajectory). 

 
 

★ Interval Time to Update Screen 

Interval time to update screen can be changed. Animation is so smooth as to decrease value. 
 

★ Track Line File 

Track line file is output. When this setting is on, Cycle time starts up after simulating. 
 

★ Simulation Stop 

Show Colliding Planes while Simulation 
Parts collided is displayed while simulation. 
Stop the Robot when Collision is Detected 
Robot motion is stopped when parts is collided. 
 

★ Conveyor Stop 

Selection is made between "when a robot stopped, whether the conveyor input of the robot is only 
stopped," or "when all robots stopped, whether the conveyor input of all robots are stopped." 
 

★ Robot Animation 

Place a check mark to operate a robot on the main view with a virtual teach pendant. 
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When unchecked the robot can be operated with the teaching panel plug-in. 
 

4.11.7[Option Settings] -> [Terminal] 

 

 
 

★ Log 

Output and setting of Terminal log file is changed. 
Un-checking [Accept the System Default Path], any path can be set. 
 
* Path is saved in the project. When the project is loaded in other, the Path is used and log saved. 
 

★ Current Folder 

When a command with the file operation is executed, a folder to save/read the file is specified. 
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4.11.8[Option Settings] -> [Controller] 

 

 
 

★ Synchronous 

Selection is made whether the setting of the robot controller is saved into the project. 
When the box is checked, the setting of the controller side is reflected to the main application side 
every time when the project is saved. 
Uncheck to avoid synchronizing the setting of the main application with the controller setting. 
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4.12Undo Relocation 

When an entity such as a robot or a workpiece is repositioned by mistake, this function can return the 
entity to the previous position. 

 

 
 

By pressing the [Undo] button, the latest reposition processing is canceled, so that the robot returns to 
the state before that processing was applied. 
In addition, by pressing the [Redo] button, the reposition processing which was canceled by pressing 
the [Undo] button will be redone for one execution done just before pressing the [Undo] button. 
This function can keep records for the latest 100 times of reposition processing. 
 
When multiple entities have been repositioned, it is not possible to cancel only the reposition 
processing of the entities other than the one which was just repositioned. 
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4.13Orientation of Points 

On the Teach Point Align dialog, it is possible to set a constant value to the orientation of a teaching 
point which is added to a project in the click teaching mode (each value of the OAT coordinate). 

 This function is effective while the Teach Point Align dialog is being displayed. 

 
 

To determine the orientation of the teaching point added, the following five methods are usable. 
 

[Reference Point] The teaching point is added at the same orientation as the 
registered teaching point. 

[Reference Robot] The teaching point is added at the same orientation as the 
current posture of the registered robot. 

[To Work Surface] The teaching point is added perpendicularly to the workpiece to 
which it is added.  

[Direct] The teaching point is added with the directly entered values.  
When [Reference Teach Point] or [Reference Robot] is selected, 
when the [Copy for Direct] button is pressed, the values of the 
current robot (or teaching point) will be reflected into the entry 
form of [Direct]. 

[None] The teaching point is added with the Teach Point Align function 
not effective. 
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4.14Installable Position Analysis  

For more than one teaching point, a position usable for teaching can be analyzed. 

 

 
 

3On the extended application menu, select [Installation Position Analyzer]. 

4The installation position analysis screen will appear. Select a robot to be analyzed, and enter 
analysis interval and analysis range at the [Settings] item. 
It is possible to set up as an option whether to consider interference during analysis and whether to 
allow jumping during analysis. 
At the [Teaching Point Setup] item, move the teaching points applicable to analysis from the left list 
box to the right one, and select the [Start] button. 
When analysis has been completed, a list of the analysis results is displayed. 
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In the list of the analysis results, double-click a column. The robot will move to the coordinate of the 
column. 
 
[ ]: Succeed, [ ]: Failed, [ ]: Collided 
 
In addition, the analysis results are displayed as   symbols on the view.   
 
Each color is applied [ ]: Succeed, [ ]: Failed, [ ]: Collided 
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4.15Conveyor 

To conduct simulation utilizing conveyors, place a robot with which a conveyor or conveyors were set 
up in a project to create a work-use conveyor. 
 
Hereinafter, this chapter describes creation of work-use conveyors. 
 

 It means a robot set conveyor axis in controller setting. Set the axis using wizard application or there 

are robots in the library to which conveyors were set up in a standard manner.  
 
About Conveyor Work 
The work-use conveyor is a workpiece equipped with conveyor functions, which is used to perform 
simulation utilizing conveyors. 
By attaching (placing as a child) a workpiece that you wish to transfer to the work-use conveyor, the 
transfer of the workpiece can be simulated. 

 
 

 
 
 
 
 
 
 
 
 
  
 
 
 Speed

 : Set in the range of 0 to 9999 [mm/sec]. 
Direction : Select either Forward (normal direction) or Inverse (opposite direction). 
Joint type : Select one of the three types: XSlide (move along the X-axis), YSlide (move along the 
Y-axis), and Zslide (move along the Z-axis). 

4.15.1How to Create Conveyor Work 

This section describes the procedure to create a conveyor work. 

4.15.1.1Creating a conveyor work 

1 In the extended application menu at the top of the screen, select [Conveyor Settings] tab. 
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2 
In the [Edit] tab of the dialog, press the [Add] button. The file selection dialog box will 
appear.  

3 When the added work-use conveyor has been displayed in the list, select the work-use 
conveyor on the list, and set up speed, direction, and joint type. 
- Speed: Set in the range of 0 to 9999 [mm/sec]. 
- Direction: Select either Forward (normal direction) or Inverse (opposite direction). 
- Joint type: Select one of the three types: XSlide (move along the X-axis), YSlide (move along the 
Y-axis), and Zslide (move along the Z-axis). 
Press the Close button to exit the ConveyorSettingGUI window. 

4 Double-click the work-use conveyor on the view to move it to an arbitrary position. 
When there is a workpiece that you wish to transfer, add the workpiece, and drag and drop it onto the 
work-use conveyor in the tree pane. 

 
 

The direction of the joint is provided by the world coordinate system. 
In the same manner as applied to the workpiece, a work-use conveyor can also be repositioned by 
double-clicking its name in the tree pane or right-clicking and selecting [Position] -> [Assigned 
Position]. 

 

4.15.1.2Deleting a conveyor work 

To delete a conveyor work, in the same manner as applied to the ordinary workpiece, right-click the 
work-use conveyor, and select [Delete] from the menu. 

 

4.15.2Optional functions on the conveyor menu 

Right-click the work-use conveyor on the tree pane. Then, the conveyor menu will appear so that some 
functions which cannot be set up on the Conveyor Setting window can be added. 

 
Location : Register/recover a position. 
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Limit 
Switch 
Position 

: Specify a distance to a limit switch. 

Shift 
Value 

: Set a position to start moving. 

Reset 
position 

: Register/recover an initial position. 

 
Change of the speed, direction, or joint type of a work-use conveyor 
 
To change speed, direction, or joint type, use the Conveyor Setting window or the conveyor menu on 
the tree pane. 

 
A teaching point is added to the tool end (the end of the robot arm when no tool is attached). 

 

4.15.4Pair setting of a work-use conveyor and a robot 

When more than one work-use conveyor is present, it is necessary to set up which robot is associated 
with which conveyor work. 

 

 
 

This pair setting of work-use conveyor and robot can be made on the [Pair Settings] tab on the 
Conveyor Setting dialog. 

 
 

Addition/Teaching of Model Transferred on Work-use Conveyor 
This section describes how to add/teach a model to be transferred on a conveyor work. 

 

4.15.3.1Addition of a model transferred on a work-use conveyor 

1 Right-click a conveyor work. From the displayed menu, select [Add] -> [Environment] -> 
[Work…] or [Obstacle…]. On the shape file selection dialog, add a model that you wish to 
transfer on the conveyor. 
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2 Arrange the work. Then, right-click the conveyor work, select [Reset Position] -> [Record] 
from the menu to record the initial position of the model. 
 

 
 
 
 

4.15.4.1Addition of a teaching point to a model 

To add a teaching point to an added model, add it in the same way as applied when adding a teaching 
point to an ordinary workpiece. 
 

4.15.4.2Creating a teaching program based on a created 

teaching point 

 
This section describes how to create a teaching program based on a created teaching point. 
 

1Add a new program on the program table. 
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2To reposition the conveyor, right-click the work-use conveyor, and select [Current Position...] 
from the menu to display the conveyor current value dialog. 

 

 
 

On the view, select a teaching point that you wish to create a teaching program. 
Change the conveyor’s value. 
By pressing the [Program step][Move][LMOVE]button of Program menu on Program tab, the 
programming steps for the moving instruction will be added to the program. 
 
The program steps for the moving instruction can also be added by dragging and dropping a teaching 
point onto the program name section on the program table. 
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4.16Simple Gun Wizard for Painting [for Paint] 

By using the paint gun wizard, an original tool can easily be generated. In addition, it is also possible to 
generate the spray shape. 
 
4.16 Simplified Creation of Paint Gun 
The paint gun creation allows the simplified creation of original tool. 
In addition, the creation of the spray shape is also allowed. 
 

4.16.1Paint Gun Wizard  

By using the paint gun wizard, it is possible to generate an original tool by reading in a model of gun or 
bell, which is used as a base, and then changing the settings of length, angle, converted tool coordinate 
values, or coordinate values of the offset from the origin of the model. 

 
The generated tool can be attached to the end of the robot arm by K-ROSET. 

 

★ Tool name 

Enter a tool name. A tool folder is created with this name. 

★ Resetting 

The tool file already created is read, and the setting is applied to each parameter below. 

★ Bracket length 

Length of the bracket. 

★ Gun length 

Length of the gun. 

★ α 

Angle of the bracket length and the gun length. 

★ Distance of a gun 

The distances from the tip of the gun to a painting target can be set. 
Change of this value changes tool converted value automatically. 

★ Tool converted value 

The position of the tool arrow can be changed. 
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★ Model zero offset 

The position of an origin of the tool can be shifted. 
 

★ Follow-on check of paint shape 

When a check mark is placed and a gun is created, the paint shape set on the paint shape screen is also 
created concurrently. 

★ Creation 

A paint gun is created according to each parameter. 
The tool file is saved in MyKHIlibraries¥Tools. 

★ Attachment 

A paint gun is created according to each parameter, and the tool file is saved in MyKHIlibraries¥Tools. 
The file is attached to the robot. 
When there are several robots, the screen selecting a target robot is displayed. 

★ Setting 

The paint shape setting screen is displayed. 
 

4.16.2Spray Shape Settings  

On the spray gun wizard screen, press the [Spray Pattern Settings] button. The spray shape settings 
screen will appear. 
On this screen, it is possible to generate a spray shape model attached to the tool end by reading in a 
painting model of spray or bell, which is used as a base, and then changing the settings of parameters, 
colors, and so on. 

  

 
On the setting screen of spray shape, various parameters or colors can be set, and a spray shape model 
to be attached to the tip of the tool can be created. 
 

★ Paint shape 

Spray gun and a bell gun can be selected. 
Upper side W, upper side H, lower base W, lower base H, and length Z are set for the spray gun. 
Upper side radius, lower base radius, and length Z are set for the bell gun. 

★ Color 
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Press a color to display the color palette, and spray color can be set. 
Display of shape 
Unattached. 

★ Transparency 

Transparency can be set. 
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4.17Edit Paint instruction [for K Series] 

 

 
 

The buttons are described as follows. 

 
[Add] : The content of the current Paint is newly appended to the bottom of the 

program. 
[Insert] : The program instruction currently selected on the program table is inserted 

into the selected line on the program. 
[Delete] : The program instruction currently selected on the program table is deleted. 
[Modify] : The program instruction currently selected is corrected with the content 

specified on the Paint tab. 
[↑] : The program instruction currently selected on the program table is moved 

one line above on the program. 
[↓] : The program instruction currently selected on the program table is moved 

one line below on the program. 
 

Use the Paint function to add one 
Select the program item to which you wish to add a program instruction, and choose the [Paint] tab at 
the bottom of the screen. 
In the [Paint] window, choose the target program instruction. Enter values, and press the [Add] button. 
 
The selected program instruction will be added to the program. 
 

 
Use the Paint function to edit the instruction 
The content of each program instruction can be edited using the PAINT function. On the program table, 
choose a program instruction that you wish to edit, and select the [Paint] tab at the bottom of the screen. 
Then, it will be possible to edit the program being selected currently. 
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 Memo 
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4.18Create Painting Program (3 Points) [for 

Paint] 

Only the teaching points belonging to the group directly below the project can be selected. Setting 
any three points, Teaching point is created on the basis of three points teach method.  

 

 

 

★ Setting of Program Create 

Current Robot……Target robot is displayed. 
Program Name……Created teaching Point group or program name is displayed. 
Spray Number……Signal number for spray instruction is set. 
Spray On Delay……Injection delay of spray is set. 
Spray Off Prec…… Off preceded time of spray is set. 
Generate Intermediate TPs……Intermediate teaching point is outputted. 

★ Ref. Point Location 

[Use Current Position]……Tool coordinate current robot is obtained. 
 

★ Settings 

Splay Length……Pitch of creating teaching point is set. 
Lateral Offset……Offset distance is set. 
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Painting Method……Type spray path is set. 
Angle of Painting……Angle in spraying is set. 
Offset1……Offset distance to cross direction is set. 
Path……One way or Round Trip 
Psi Start……Elevation angle of starting point is set. 
Psi End……Elevation angle of ending point is set. 
T Rotation……T coordinate of created teaching point is set. 
 

★ Teaching point / Program Creating 

[Create TP]……Setting is executed. 
[Create PG]……Setting is executed. 
[Clear]……Program is cleared. 
 

★ Results 

Log in creating program is displayed. 
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4.19Create Painting Program(Copy) [for Paint] 

To create a teaching program which repeats the same pattern more than once, for example, 
painting a wall, using the PaintPathCopy function allows you to create a program easily. 

 
 

This section describes each item. 
Current 
Robot : 

The target robot of creating a teaching point and a teaching 
program is displayed. 

Program 
name : 

The name automatically assigned when a program is 
created. 
This is “(group name).NewGroup” by default. 

 
Settings for teaching point automatic creation 

group : Specify a group containing the teaching points that 
you wish to make a pattern. It is necessary to contain 
the teaching points that you wish to make a pattern 
(red frame), and the ones that specifies a direction 
(yellow frame) in the group. 

 
Pitch 
(mm):  

Specify an interval of the target teaching points of 
patterning in mm. 

Number: Set how many times the pattern is repeated. 
Direction : For the direction taught in a pattern when the pattern 

is created repeatedly, select from reverse or normal 
direction. 

Reverse 
direction 

A method to create teaching points so that teaching 
goes from the last point to the first point in the 
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reverse direction after going from the first to the last 
points in a pattern. 

 
 
 
 

Normal 
direction 

A method to create teaching points so that teaching 
always goes from the first point to the last point in a 
pattern in a fixed direction (normal direction). 

 
 

[Create] 
button 

Creates the group and teaching points contained in it 
according to the settings above. 

[clear] 
button 

Erases all the created teaching points by group. 
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4.20Time Line 

When simulation is executed and cycle time information is output, The trace file recording the 
operation then is output. The timeline is the extended application using the file to check motion 
details focusing on the motion time. 
Posture of the robot at any timing within the motion time or conveyor information can be checked 
on easily. 
 
Names of each part 

 
 

Control panel : Button to execute each function and control for setting are disposed. 
Item area  : The robot and conveyor on a view are listed. 
Click this area to read any trace file. 

  Conveyor and External axis is not supported.  

 
Time pointer : a pointer to be moved by repeat or left-click. Data of the position (time) of 
this pointer is applied to a robot. 
Status bar  : Time of the position of time pointer, tick, and conveyor value are displayed. 
When the process taking time is executed, a progress bar and a message are displayed. 
When there is a mouse in the item area a file name of the trace file is displayed here. 
Time gauge : When a repeat start position is set to 0 seconds, timing information is 
displayed. 
Clicking the left button in this area will be the command for all items. 
When there is a mouse in this area, all background colors in the item area turn darker. 
Data cell  : Repeat point and interference information of each robot are displayed. 
Clicking the left button in this area will be a command valid only to the robot allocated in the area. 
When there is a mouse in this area, the background colors of the applicable items in the item area 
turn darker. 
Common operation between time gauge and data cell: 
Dragging the right button in the time gauge or a data cell area can move a display time zone back 
and forth. The movement is like a sliding motion of the time gauge and data cell area to right and 
left on the screen. Scaling can be larger or smaller by dragging the central button in the similar 
way. 

★ Start 

Select "Timeline" of the plug-in menu and click for start. 
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When there is not any robot on a view, the following dialog is displayed and the timeline does not 
start. 

 

 
When there is any robot, all robots, and conveyors if any, are started with being listed in the item 
area. 

 

 
 

General description of button in the control panel and controlling 
A: Close button 
 Finishes timeline. 
B: Cue button 
 Moves a repeat pointer to the top. 
C: Frame return button 
 Returns a repeat pointer for 1 repeat pitch. 
D: Repeat button 
 Stars auto-repeat from the position of the repeat pointer to the end. 
 When the repeat button is pressed, this button turns a pause button. 
 When the pause button is pressed during repeat, the robot stops temporarily. Press again 
to continue repeat. 
E: Frame advance button 
 Advances the repeat pointer for 1 repeat pitch. 
F: A repeat stop button 
 Stops the repeat. 
G: Termination button 
 Moves to the terminal point of data read in timeline. 
H: Interference check On/Off check box 
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 When this check is enabled, interference symbol is recorded at the position on the 
timeline when interference  during reproduction occurs. 
I: Reproduction pitch setting control 
 The smallest value is minimum tick value described in a trajectory file, and  
 The pitches repeatable comfortably are different depending on the performance of the 
PC. 
J: Automatic scaling button 
 Adjusts the read trajectory file automatically so that it is displayed in full width of the 
display scale of the timeline. 
K: Scale reduction button 
 Reduces the scale unit of the timeline, and displays more range of time. 
L: Scale enlargement button 
 Enlarges a scale unit of timeline, more detailed information is displayed. 
 Functions effectively when the repeat pitch is small. 
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4.21Simple Shape Generator 

In the creation of the simplified shape, a simplified model moving on K-ROSET can be created. 
Select creation of the simplified shape from a plug-in menu. 
 
Select a tab from box shape/square column/pyramid/column/circular cone/box shape 2/column 2 
tabs/Sphere, and specify the dimensions of the created model. Click the work button to create the 
model as a work, and click the obstruction button to create the model as an obstruction in the 
world origin.   

 

   
 
 

★ File export 

A file saving dialog is displayed, and a model of the parameter entered with any  
name is saved. 
 

★ Work 

A model of the entered parameter is added to a view as a work. (*) 
Immediately after creation of the model, the model is provided at the world origin. 
 

★ Obstacle 

A model of the entered parameter is added to a view as an obstacle. (*) 
Immediately after creation of the model, the model is provided at the world origin. 
 

 (*) The created file is saved as "Work + consecutive number" in MyKHILibrary folder 
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★ Input 

New : It adds the newly-created model. 
Replace : It is able to modify the simple model. By clicking the Env model created by Simple 
Shape Generator, the model name is automatically added to the list. The model parameters are 
shown. 
 
Immediately after creation of the model, the model is provided at the world origin. 
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4.22View management 

View management is the function to display in a registered viewpoint. 

    
 

★ An initial registered view 

Each viewpoint centering the world origin is prepared by default. 
Click the icon button or press the applicable shortcut key on display to change a viewpoint. 
 

★ User view 

Press the registration button with the viewpoint for registration to register the viewpoint, and to 
enable 1 to 10 buttons on the side. 
Press 1 to 10 buttons to change to the registered viewpoint. 
[Load] ... Cancels the registered user view, and read to set the viewpoint setting file (*.xml). 
[Save] ... Saves the registered user view into the viewpoint setting file (*.xml). 
[Clear] ... Cancels the registered user view. 



 

130 



 

131 

4.23Measurement of distance  

Measurement of distance is the function to measure the clicked direct distance of two points. 

   
 

1 Press Add button to change a cursor and to wait the measurement. 

2 Click the first point to measure to display an auxiliary line from the clicked point to 
the current cursor. 

3 Click the second point to measure to display a straight line to connect the first point 
and the second point on a view, and the distance. 

 
[Delete] ... Result of the measurement selected from the list is deleted from the list and the view. 
[Clear] ... All results of the measurement are deleted from the list and the view. 
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4.24Collision log 

The collision log displays the collision conditions of the robot teach operation and the simulation. 

 
 

[Column double click] ... Returns the layout condition when the collision occurred. 
[Restore Layout] ... Turns enabled when the column is double-clicked and the layout is returned. 
Returns to the posture before the column is double-clicked. 
[Clear] ... Deletes all interference logs. 

 Memo 
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4.25Simple Teach 

This section describes the joint dialog that is displayed when a robot model is clicked. 

 
This joint dialog is displayed at the bottom right of clicking point in the initial settings. 
To fix the posture, please click the top left of the joint dialog. 
 
How to use 
Drag the track bar or input the value in the text box. 
 
How to set 
Clicking on the dialog, a menu is displayed. 

 

 
Margin for click-point: Set the distance of dialog from the clicking point. 
Orientation: Switch the displaying mode of the dialog. 
Warning: When approaching the setting percentage of the motion range, the color changes. 
 

 * If Controller axes limit turn off on the Teach Panel, the value cannot set beyond the motion 

range. 
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4.26Video recording 

This section describes a method for recording moving images. 
 

1Select [Video recording] of the plug-in. 

2The setting dialog is displayed. Specify recording type/repeating speed and press [OK] button. 

 
 

3The dialog of [Name and save] is displayed. Specify the destination/file name, and press 
[Save] button. 

4Set the compression format of the video, and select [OK]. 

5Execute simulation. 

6Press the temporary stop button to stop temporarily. 

 
 

Press the temporary stop again to start recording.  
 

7Click [Video recording stop] button to stop the recording. 
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4.27Program conversion 

This section describes program conversion. 

 
 

Motion commands of the program or points added to the program table can be converted with a 
specified method in the program conversion. 
Preview (point marker) is displayed before execution. 
 
Green ... Point of conversion source 
Light green ... Point succeeded in conversion 
Orange ... Point failed in conversion 
 
Source of conversion 
The program for the conversion is selected. 
A robot, a group, and a program are selected from the combo box sequentially. 

  The tab of the conversion method turns disabled until the program is selected. 

 
Destination of conversion 
The method to add converted program to is specified. 
Select a robot of destination of conversion from the combo box, and enter a program name with a 
keyboard in [Program] text box. 
 
Application area 
All 
Applied to all motion commands of the program of the selected source of conversion. 
 
Specification 
Applied to the motion commands in the specified column of the program of the selected source of 
conversion 
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XYZ shift 

  
A program is converted into X, Y, and Z direction with respect to the base converted value of the 
robot. 
Select the conversion method (offset value, specified value), and enter a numeric value into X, Y, 
and Z. 
Putting a mark into a check box enables the input box. 
Offset value 
A motion command is offset for the numeric value entered. 
Specified value 
Value of X, Y, Z of the motion command is specified in the entered value. 

 

Mirror image 

  
Motion command is mirrored with respect to the specified axis of the base converted value. 
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Tool shift 

 
 

Offsets for the numeric value entered into X, Y, and Z direction of the tool converted value. 
Putting a mark into a check box enables the input box. 
 

Conveyor axis shift 

  
 

Conveyor value of the motion command is converted. 
Select the conversion method (offset value, specified value), and enter a numeric value into the 
CV. 
Putting a mark into a check box enables the input box. 
The conveyor axis shift is displayed by selecting a robot with the conveyor axis as the robot of the 
source of conversion. 

 
Offset value 
A motion command is offset for the numeric value entered. 
 
Specified value 
Value of X, Y, Z of the motion command is specified in the entered value. 
Turn to comment when inverse conversion is failed. (Default: ON) 
 
Display of the motion command of the program after conversion is set. 
When the operation to convert the converted values into each axis values is disabled during 
conversion work of the program (for example, the robot cannot posture), the commented command 
before the conversion is displayed. 
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  Default is ON. 

 The case of the robot motion out of range is included. 

Marker size 
The marker size of the preview is set to Large (10 point), Middle (4 point), and Small (1 point). 
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4.28HANDLING Clamp(for Handling) 

 

Select “Handling Clamp” from the extended application menu. The Handling Clamp screen will be 
displayed. 

 

 
 
 

★ Application 

Select number 2 in the case of handling application. 
Number 1and 3is unsupported 
 

★ Output Signal for ON 

Signal for ON is set. 
When signal is ON, workpiece is gripped. 
 

★ Output Signal for OFF 

Signal for OFF is set. 
When signal is OFF, workpiece is taken off. 
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4.29Wizard to Set External Axis 

This section describes the function to set a external axis by the wizard. 
 
*Number of assignable axis depends on application or controller type. Handling Econ:9, 
D,D+con:7, the other:8 

Selecting a robot 

 
Select the operating mode. Next select the target robot. The robot information is displayed. 
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Layout 

 
Axis Specifications 
 Conveyor 
  The external axis is set as conveyor axis. 

 This specification cannot add the model. 

 
 Tool 
  The external axis is set as tool for servo-hand, servo-gun and so on. 
  The model is automatically added the tool of the robot. 

   
*Parent object is the attached tool. 
 
 Positioner 
  The external axis is set as table positioning the workpiece. 
  The model is attached the selecting parent object. 

     

 
Travel, Rotation 
The external axis is set as a truck of the robot. 
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The model is attached the selecting parent object. And objects in the selecting parent object is 
attached the model. 

 

 *The orientation of the adding model depends on the base transformation of the robot. 

 *[Adapter] model is added. Positioning the adapter model can change the distance of the robot 

and the truck.  

  

★  Dual model 

  Set dual servo mode 

★  Parent object 

  Select the target object to attach the external axis model. 

★  Child object 

  Select the target object attach to the external axis model. 

★  XYZOAT 

  Set the offset value to the parent object origin 

★  Model File 

  Select the model file (*.stl) of the external axis with Selecting dialog. 

 

Controller settings 
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★ Type 

Set the target axis and how to move. 

★ Direction 

 Set the direction with plus or minus. 

★ Upper Limit 

Set the upper limit of motion. 

★ Lower Limit 

 Set the Lower limit of motion. 

★ Max Speed 

 Set the max speed. 

★ Accel Time 

 Set the accelerate time to reaching max speed from stopping 

★ Cooperative 

 Set the cooperative or synchronization 

★ Controller File 

 Set the controller with AS file. 

 * All of setting depends on the file in case of loading AS file. 

 
Confirmation 

  
Confirm the setting items. 
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Operation(Add) 

1Select [Wizard to Set External Axis] from menu. 

 
*The application is not run, unless a robot is added to view. 

 

2Select the operation type and the target robot after the dialog is opened. 
Selecting the robot, the type of the robot are the tool are displayed 

 

3Click [Next] 

4Select the specification. 
Here describes travel-unit. 
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5Click the button of the model file. 
Select the model file(*stl) on the file selecting dialog. 

  

 *Unless the model file is selected,  [No Shape Data] is applied. 

  
Select the model file(*stl) on the file selecting dialog. 

6Select the parent object. 
Select the taget robot. 

 *Set the child object in case of attaching to the external axis. 

7Set the distance of offset to the model origin of the parent object. 
Set the parameters as follow. 

  

8Click [Next] 
Set the detail of motion. 
Set the limit of the motion range and the max speed. 

9Set the parameters as follow. 
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Click [Next]. 
Confirm the settings. 
Check the target robot, the axis number and the motion type. 
If its settings are different, Click [Back]. 

10Click [Ok]. 
The Configuration on the Layout is changed. 
PC-AS is rebooted, and the wizard dialog is closed. 
 
Operation (Delete) 
Select [Wizard to Set External Axis] from menu. 

 
Select the target robot and [delete] after the wizard dialog is displayed. 
Selecting the robot, the type of the robot are the tool are displayed 
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11Click [Next]. 

12Select [OK] after checking the settings/ 
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4.30Action 

This function can draw Pint and track line to a work- piece or move the model with robot signal. 

.  

List 
The settings on Action are displayed. 
Action Type 
Select a type of action. Settings of each action describe as next term. 
Add 
Setting is added. 
Del 
Selecting setting is deleted. 
Cancel 
Action dialog is closed. The settings are aborted, unless the settings are added to the list. 
 
Model move 
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★ Hand Model 

If the term is valid, you can set the claw of hand. 

★ Robot, I/O No. 

The target robot and the signal are set. 

★ Tool 

Set the target tool in case of hand mode 

★ Moveable Model 

Select the target model. 

★ Pitch 

Set the speed of the model. 

★ Limit 

Set the limit of motion. 

★ Direction 

Select the direction of model. 
Linking Moveable Model 
Select the model coupled motion. 

★ Direction 

Select the direction of Linking model. 

★ Set I/O when Collide. 

Colliding the model, the setting signal is turned on. 
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Track Line 

 
★ Robot 

Set the target robot. 

★ Work 
Select the enviroment coupled the track line. 
 

 

★ Track Line 
Input the name of the track line. 

               
 

Paint Path 

 
★ Robot 

Set the target robot. 
*Paint robot only 

★ Work 
Select the enviroment coupled the Path Line. 

★ Track Line 
Input the name of the Path line. 
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4.31View Rotate 

This function can revolve the view by specified degree as base on world. 

.  
Pitch 
Set the increasing/decreasing degree. 
The settings on Action are displayed. 
Close 
View Rotate dialog is closed. 
Arrow 
Clicking the arrow, the view can be rotate. 
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4.32Signal Graph Display 

This function is to monitor changes of robot I/O signal and display the graph. 

 

 
Functions of each section are as follows. 

★ Time scale 

Adjust the screen size (pixel) per second. 

With smaller value, more data can be displayed on a screen. 

★ Grid line interval 

Adjust the interval of the grid line width drawn on the graph. 

With smaller value, more grid lines can be displayed on a screen. 

★ Time interval 

Adjust the interval of the elapsed time display drawn on the graph. 

With smaller value, more time can be displayed on a screen. 

★ Start button 

Start monitoring. 

Switch [Pause] or [Restart] during monitoring. 

★ Stop button 

Stop monitoring. 

Valid when monitoring is started. 

★ Clear button 

Clear the monitored results. 

★ Close button 

Close the screen. 

It is impossible to close during monitoring. 
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File Menu 

★ Export as CSV format 

Select [File]-[Export Csv file] to save the displayed signal data as CSV format. Files can be 

output during stop or pause. 

★ Read as CSV format  

Select [File]-[Import Csv file] to display the signal data saved as CSV format. Files can be 

read during stop. 

It is impossible to start monitoring when importing files. 

Select [File]-[Close Csv file] to switch screen to the monitor screen that of before file 

reading. 

Edit Menu 

★ Data settings 

Select [Edit]-[Data settings] to set signal data to be monitored. 

Data settings can be operated during stop. 

 

Display Menu 

★ Display settings 

Select [Display]-[Option] to change various settings related to display. 

 

[Data settings screen] 

 

★ Data interval 

Set the interval to obtain data from the controller. 

★ Max buffer size 

Set the maximum data size that can be displayed on this screen. 

When the data interval is 100 msec and the max buffer size is 12000, it is possible to 

display for approximately 20 minutes. 
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100(msec) × 12000 = 1200 sec (20 minutes) 

★ Signal addition 

Add a signal to be monitored to the right side list on I/O signal settings. 

Multiple signals to be monitored can be selected and added from the left side signal list. 

Press [->] button on the center of the screen and add to the right side list. 

Signal names are defined by the controller. It is impossible to edit them. 

★ Signal deletion 

Select a signal to be deleted from the right side signal list and press [<-] button on the 

center of the screen. 

★ Signal display position change 

Select a signal to be changed the display position from the right side signal list and press 

[Up] or [Down] button on the top of the list. 

★ Blankline addition 

Press [Blankline] button on the top of the right list to add a blankline to the selected 

position. 

 

[Option] 

 

★ General tab 

Set refresh interval of the screen, font and graph display area. 

With larger refresh interval, flicker on the screen can be restrained. 

★ Title tab 

Change the title display position or combine cells. 

★ Data display tab 

Set color or width of the data line, color or transparency of the stick chart, and display 

format. 

★ Cursor tab 

Set the cursor to be displayed during monitoring stop. 
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4.32Operation Procedures 

1Select [Signal graph display] on plug-ins menu. 

 

2 Select [Edit]-[Data Settings] on menu bar of signal graph display. 

 

3 On data settings screen, add a signal to be monitored to the right side list. 
Select a signal to be monitored from the left side list and click [->] to add to the right side list. 
Multiple signals can be selected and added at once. 
Click while pressing [Ctrl] key to select and add signals that are not consecutive. 

 

4 Press [OK] button to reflect the set signal on the monitor screen. 
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5 Press [Start] button to start monitoring signals. 
Adjust time scale, grid line interval, and time interval to make the screen clear. 

 

6 Press [Pause] or [Stop] button to stop monitoring. 
Press [Pause] button to restart monitoring. 

7 Export the monitored results on CSV file. 
Export the monitored results on CSV file as necessary. 

 

8 Click the graph to display a cursor. 
Click the graph during pause or stop to display a cursor. 
Also, signal status of the cursor position is displayed on the right side of signal number. 
The indicator is displayed only when signal is ON. 
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MEMO 
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4.33Start Page  

The start page is available in order to make the project creation or edit easier. 
 
With V1.6.8 or newer version, the start page is displayed when starting K-ROSET. 
 
A screen example is as follows. 
 
 

Refer to the following explanation for each item. 

Create a new project 

Display a dialogue to input a new project name. 
 

Open a stored project 

Display a project load dialogue. 
 

Edit a project with quick 

builder 

Quick builder is a function to support project creation. 
Exclusive dialogue is displayed and the basic project 
can be created according to the procedures. Refer to 
the next chapter for the functional explanation. 

 

Save.. 

Display a dialogue to overwrite the current project. 
 

Recently used projects 

There are shortcut icons for recently edited projects. 
They can be deleted by DEL key. 

 
 
 
 
Layout tab can also be selected. The object can be operated with layout tab when selecting stored 
projects or after creating a new project. 
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4.34Quick Builder 

Quick builder is a function to support project edit. 
It is available with V1.6.8 or newer version. 
 
A basic project can be created rapidly according to the guidance. Also, stored projects can be 
edited by quick builder. 
 
Refer to the following procedures. 

1 Select start page tab on K-ROSET. 
Following screen is displayed. 

2 Start operations－Select project edit menu on quick builder. 
Following screen is displayed. 
 

 

 
The left side of the screen shows items for project settings. The item currently being edited is 
shown in pink. The basic setting of a project can be completed by setting all items from the top. 
Click Next button to jump to the setting screen of the next item. Click Back button to return to the 
previous setting screen. 
 
It is not necessary to edit each item in order. Unnecessary items can be skipped and only required 
items can be edited. 
It is not necessary to add every item. Setting screens can be edited always as necessary. 
（However, tool and program cannot be edited unless the robot is added.） 
 
Click Close button to finish quick builder. 
Items that cannot be edited by quick builder can be edited with layout tab. 
 
All the added items are displayed on the view. Proceed a project creation while checking items on 
the view. 
 
Refer to the following explanation for each edit screen of quick builder. 
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4.34.1Robot 

Add a robot, delete a robot and edit an installation position of a robot. 

 

 
Refer to the following method to add a robot. 
There are two ways to add a robot; from library or from file. 

Add from library 

1Click add button. 
A dialogue [Addition of Robot from Library] is open. 

2Select an application, a controller and a model series. 
By select a series, model icons for that series are displayed on the right side of the screen. 

 

3Select a model and click Open button. 
The selected robot is added on the view and the layout. 
Use [icon] to change size of the icon. 
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Icon size selection screen 

 

Select and add a file 

1Click Add button. 
A dialogue [Addition of Robot from Library] is open. 

 

2Click Open Files button on the lower left of the screen. 
A dialogue [Addition of Robot from File] is open. 

 

3Click Reference button on the model field. 
A dialogue [Open files] is open. 
Select a folder with the robot file and select the robot file. 
Installed robots are located in the install file folder ¥KHIlibraries¥Robots. 

4Select a model and click Open button. 
A dialogue [Open files] is open. 
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5Select a controller file list on the controller field. 

 

A format of a file name is [Model name_Controller soft AS version.khirc]. 
AS version varies depend on the application or the controller. 

6Click Open button. 
A robot is added. 
The operation is completed. 
 

Refer to the following method to change a pose and an installation position of the robot. 

Set a pose 

1Select an object robot icon and click Setting button. 
A dialogue [Setting of Robot] is open. 

 

2Click Pose on the left side of the screen. 
A pose setting screen is displayed on the right side of the screen. 

3Select a pose. 
Select one from Floor, Ceiling, Wall, Wall 2 or Angle specification. 
At the time of selection, the robot on the view is positioned to that position. 
Angle field is valid only when selecting Angle specification. 

 
A pose 

With K-ROSET, all poses can be selected for all models in order to consider various layouts. For 
some models, therefore, the pose that cannot be set with the actual machine can also be 
considered. Consult Kawasaki to find out whether the specific pose can be set with the actual 
machine. 
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Change an installation position 

1Select an object robot icon and click Setting button. 
A dialogue [Setting of Robot] is open. 

2Click Position on the left side of the screen. 
A pose setting screen is displayed on the right side of the screen. 
 

 

3Change an installation position and a pose. 
At the time of changing values, the robot on the view is located at the appointed position and pose. 

4Click OK to confirm. 
Click Undo button to return to the previous position. 
It is impossible to return after confirming by OK. 
The operation is completed. 
 
Refer to the following method to delete. 

Delete a robot 

1Select an object robot to be deleted. 

2Click Delete button. 
A confirmation dialogue is displayed. 
Click Yes to delete or click No to cancel. 
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4.34.2Tool 

Add a tool, delete a tool or edit an installation position. 

 At least a robot needs to be added before operating a tool. 

 

 
Refer to the following method to add a tool. 
There are two ways to add a tool; from library or from file. 

Add from library 

1Click Add button. 
A dialogue [Addition of Tool from Library] is open. 

2Select an application. 
A thumbnail of the selected tool is displayed on the right side of the screen. 

 

3Click Open button. 
A tool is added. 
The operation is completed. 
 



 

173 

Add by selecting a file 

1Click Add button. 
A dialogue [Addition of Tool from File] is open. 

 

2Click Reference button on the model field. 
A dialogue [Open files] is open. 
Select a folder with the tool file and select the tool file. 
Installed tool is located in the install folder ¥KHIlibraries¥Tools. 
Refer to the chapter of tool creation of the operation manual when creating a new tool. 

3Click Open button. 
A tool is added to the wrist flange of the robot. 
The operation is completed. 
 

Refer to the following method to change the installation position of the tool. 

Change an installation position 

1Select an object tool icon and click Setting button. 
A dialogue [Setting of Tool] is open. 
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2Click Position on the left side of the screen. 
A position setting screen is displayed on the right side of the screen. 

3Change a position and a pose. 
At the time of changing values, a tool on the view is located in the appointed position and pose. 

4Click OK to confirm. 
Click Undo button to return to the previous position. 
It is impossible to return after confirming by OK. 
The operation is completed. 
 
Refer to the following method to change a tool transformation value. 

Change a tool transformation value 

1Select an object tool icon and click Setting button. 
A dialogue [Setting of Tool] is open. 

 

2Click Trans on the left side of the screen. 
A position setting screen is displayed on the right side of the screen. 

3Change a position and a pose. 
At the time of changing values, a tool arrow on the view is located in the appointed position and 
pose. 

4Click OK to confirm. 
Click Undo button to return to the previous position. 
It is impossible to return after confirming by OK. 
The operation is completed. 
 
Multiple tools can be added to a robot but only a tool can be installed to a robot. 
Refer to the following method to switch the tool. 

Switch a tool to be installed 

1Select a tool icon to be installed. 
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Select an uninstalled tool to make its button valid. 
The icons for uninstalled tools are translucent. 
 

 

 

2Click Install button. 
Installation is switched and position setting screen is displayed on the right side of the screen. 
 
Refer to the following method to delete. 

Delete a tool 

 In order to delete the installed tool, it needs to be uninstalled. Also, at least a tool needs to be 

installed to a robot. 

1Select an object tool to be deleted. 
Only uninstalled tools can be deleted. 

 

2Click Delete button. 
A confirmation dialogue is displayed. 
Click Yes to delete or click No to cancel. 
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4.34.3Work 

Add a work, delete a work or edit an installation position. 

 

 
Refer to the following method to add a work. 
There are three ways to add; from library, from file or with quick generation. 
 

Add from library 

 It is added as a child object of the selected parent object. Before adding a work, decide where it 

would be added to on the tree. 

1Click Add button. 
A dialogue [Setting of Name] is displayed. 

 

2Input a name and click OK. 
A screen [Addition of Work from Library] is displayed. 
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3Click a folder and select the work file. 
If the work file is STL, thumbnail in the right side of the screen is not displayed. 

4Click Open button. 
A work is added. 
 

Add by selecting a file 

Use when selecting a file exported from CAD. 

1Click Add button. 
A dialogue [Setting of Name] is displayed. Input a name and click OK. 

2Click Reference button on the model field. 
A dialogue [Open files] is open. 
Select a folder with the work file and select the work file. 
The installed work is located in the install folder ¥KHIlibraries¥Envs. 

3Click Open button. 
A work is added. 
The operation is completed. 
 

 

Add with quick generation function 

1Click Add button. 
A dialogue [Setting of Name] is displayed. 

 

2Click Simple generation button. 
A dialogue [Generation of Work] is displayed. 

3Click an icon of the work shape. 
Items of setting size vary depend on the selected shape. Refer to the chapter of simple generation 
function for details. 
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4Input the size and click Generate button. 
A work with the set size is added. 
The operation is completed. 
 
Refer to the following method to change the settings of the work. 

Change an installation position of a work 

1Select an object work icon and click Setting button. 
A dialogue [Setting of Work] is open. 

 

2Click Position on the left side of the screen. 
A position setting screen is displayed on the right side of the screen. 

3Change a position and a pose. 
At the time of changing values, a work on the view is located in the appointed position and pose. 

4Click OK to confirm. 
Click Undo to return to the previous position. 
It is impossible to return after confirming by OK. 
The operation is completed. 
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Change appearance of a work 

Set color and transparency of a work. 

1Select an object work icon and click Setting button. 
A dialogue [Setting of Work] is open. 

2Click Appearance on the left side of the screen. 
A setting screen of color and opacity is displayed on the right side of the screen. 

 

3Click Change button to change color. 
A color selection pallet is displayed. 

4Select a color. 
Select a color on the color selection pallet and click OK. 
The color is set. 

5Drag the opacity gauge to set the opacity. 
When the gauge gets closer to the transparent side, the work would be more transparent. 
The indicated value shows the transparency. 0 means transparent and 255 means opaque. 
The operation is completed. 
 
Refer to the following method to delete a work. 

Delete a work 

When there are child objects in a work to be deleted, all the child objects are deleted by deleting a parent. 

Before deleting, make sure that the work is the one to be deleted. 

1Select an object work to be deleted. 

2Click Delete button. 
A confirmation dialogue is displayed. 
Click Yes to delete or click No to cancel. 
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Remove a check mark in the option [Display only works] to display all the currently added objects. 
Keep this check mark to be ON normally. 
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4.34.4Obstacle 

Add an obstacle, delete an obstacle and edit an installation position. 

 

 
Refer to the following method to add an obstacle. 
There are three ways to add; from library, from file or with quick generation function. 
 

Add from library 

 It is added as a child of the selected parent node. Before adding an obstacle, select a parent and 

decide where an object would be added to on the tree. 

1Click Add button. 
A dialogue [Setting of Name] is displayed. 

 

2Input a name and click OK. 
A screen [Addition of Obstacle from Library] is displayed. 
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3Click a folder and select the obstacle file. 
When the obstacle file is STL, thumbnail in the right side of the screen is not displayed. 

4Click Open button. 
An obstacle is added and the operation is completed. 
 

Add by selecting a file 

1Click Add button 
A dialogue [Setting of Name] is displayed. Input a name of an obstacle and click OK. 

2Click Reference button on the model field. 
A dialogue [Open file] is open. 
Select a folder with the obstacle file and select the obstacle file. 
Installed obstacle is located in the install folder ¥KHIlibraries¥Envs. 

3Click Open button. 
An obstacle is added. 
The operation is completed. 
 

Add with quick generation function 

1Click Add button. 
A dialogue [Setting of Name] is displayed. 

 

2Click Simple generation button. 
A dialogue [Generation of Obstacle] is displayed. 

3Click an icon of the shape of an obstacle. 
Items of setting size vary depend on the selected shape. Refer to the chapter of quick generation 
function for details. 
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4Input the size and click Generate button. 
An obstacle with set size is added. 
The operation is completed. 
 
Refer to the following method to change settings of an obstacle. 

Change an installation position of an obstacle 

1Select an object obstacle icon and click Setting button. 
A dialogue [Setting of Obstacle] is open. 

 

2Click Position on the left side of the screen. 
A position setting screen is displayed on the right side of the screen. 

3Change a position and a pose. 
At the time of changing values, an obstacle on the view is located in the appointed position and 
pose. 

4Click OK to confirm. 
Click Undo to return to the previous position. 
It is impossible to return after confirming by OK. 
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Change appearance of an obstacle 

1Select an object obstacle icon and click Setting button. 
A dialogue [Setting of Obstacle] is open. 

2Click Appearance on the left side of the screen. 
A setting screen of color and opacity is displayed on the right side of the screen. 

 

3Click Change button to change color. 
A color selection pallet is displayed. 
 

4Select a color. 
Select a color on the color selection pallet and click OK. 
The color is set. 

5Drag a gauge of opacity to set the opacity. 
When the gauge gets closer to the transparent side, the obstacle would be more transparent. 
The operation is completed. 
 
Refer to the following method to delete an obstacle. 

Delete an obstacle 

When there are child objects in a work to be deleted, all the child objects are deleted by deleting a parent. 

Before deleting, make sure that the work is the one to be deleted 

1Select an object obstacle to be deleted. 

2Click Delete button. 
A confirmation dialogue is displayed. 
Click Yes to delete or click No to cancel. 
The operation is completed. 
Remove a check mark in the option [Display only obstacles] to display all the currently added 
objects. Keep this check mark to be ON normally.  



 

185 

4.34.5Program 

Add a program, delete a program and edit an installation position. 
Select and add a program template from file. 
Only handling can be selected. 

 

 

 The generated user programs can be added from the quick builder. 

 Store program files in the install folder ¥KHIlibraries¥Program. 

 Example）C:¥Program Files¥Kawasaki¥K-ROSET¥KHILibs¥KHIlibraries¥Programs¥Handling 

 
Refer to the following method to add a program. 

Add a program 

A program is added under the controller. 

1Click Add button 
Select application folder and select a program. 

 
Only stored program in template can be selected. 

2Select a program from the list and click Open. 
A program is added in the controller with a file name as a group name. 
It is added to the program tab of K-ROSET. 
The operation is completed. 
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The added program contents can be displayed. Also, the variable can be displayed or changed. 
Refer to the following method. 

Display a program list 

1Select the added program group. 

 

2Click Setting button. 
A dialogue [Setting of Program Group] is displayed. 
Select Program in the left side of the screen. The program contents selected in the program 
selection box is displayed in the right side of the screen. 

 
The operation is completed. 
 

Display or edit a variable of the program 

Display the variable according to the selected variable and these values can be changed. 

1Select the added program. 

2Select variables （Point variable, String, Real）on the left side of the screen. 
Description according to the selected variable is displayed. 
For point variable, click variable name on the right side of the screen to move a tool top of the 
robot on the view. 
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 If the robot cannot take that pose, transformation needs to be adjusted to the appropriate position. 

3Edit the value and click OK to reflect. 

 

 
 

Execute a program 

With quick builder, select a program of Pg icon on the program screen to select an execute button.  

 In order to execute a program appropriately, need to adjust to operate with a robot that a program 
and each variable are added in advance. 

 Program can be edited by using a program tab. Refer to the chapter of the program. 

 Each variable can be edited either with quick builder or program tab. 

 

1Select Pg icon. 
An execute button becomes valid. 
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2Click Execute button. 
A program is executed. 
The operation is completed. 
 
 

Delete a program 

1Select an object program to be deleted. 

2Click Delete button. 
A confirmation dialogue is displayed. 
Click Yes to delete or click No to cancel. 
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4.34.6Option settings of a project 

Set option settings of a project. 

 

 
With quick builder, following options can be set. 

Interference setting 
View 
Virtual teach pendant 
Cycle time setting 
Program table setting 

 
Items not available on quick builder can be set on option menu of K-ROSET. 
 
Refer to the following method to set options. 

Option settings 

1Click Option button. 
A screen [Quick Option] is displayed. 
Select items on the left side of the screen to display each setting screen on the right side of the 
screen. 
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Refer to the chapter of option setting of the operation manual for details of each item. 
For the interference item, interference pairs can be set. 

4.34.7Finish Quick Builder 

After setting all items, click Finish button. 
It can be finished by Close button located in the right below screen during settings. When starting 
the quick builder again, select an icon [Edit a project with quick builder] from the start page. 
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4.35Power Consumption 

This chapter describes about Power Consumption Function. 
 
When the robot executed a series of motion program, calculates and displays power consumption 
and motor current by steps and power consumption per a cycle. 
Also, power consumption per day can be calculated or displayed by inputting running condition of 
a day. 
Before explaining the function, refer to the following precondition for this edition. 
・Following three robots are applicable to this edition. 

Model   Application AS version 
ZX165U-B501 Handling  10000V24 
BX100N-B001 Servo welding gun 21300V0E 
BX200L-B001 Servo welding gun 21300V0E 

・Only 6 axes robot is applicable. External axis is not supported. 
・The calculation object is one robot at a time.  
 

4.35.1 Method to start 

Refer to the following method to start. 

1 Select Settings/Plug-ins Setting from main menu to display a dialogue. Select [Power Consumption]. 

 
Figure 1 Plug-ins Setting from menu 

 
 

 
Figure 2 Plug-ins selection 

2 [Power Consumption] is added to the plug-in menu. 



 

192 

Select [Plug-ins]-[Power Consumption] to display a setting dialogue. 

 
 

 
 
 
 

 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 

 
Figure 3 Menu selection – Power consumption plug-ins start 

 

4.35.2 Screen Structure 

Start a screen of Figure 4 Setting dialogue screen. Set the running condition of robot and 
display the results. 
Select main menu plug-ins - Power consumption calculation and click the setting dialogue. 
Refer to the Figure 4 Setting dialogue screen for setting dialogue screen. 

 
Figure 4 Setting dialogue screen 
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Refer to the following function of this screen. 
①Checkbox [Enable Total Consuming Power Estimation of Whole Day] 
→Valid：Includes total consuming power of whole day in the results display. 
→Invalid：Not includes total consuming power of whole day in the results display. 
When the checkbox is valid, number of program execution cycles and robot operating hours need 
to be inputted. 

*Operating hours = Program execution hours＋waiting hours 
Out of operating hours (night) = Hours except for operating hours 

②Show Results button 
Close the setting dialogue and display a results dialogue. 

③Close button 
Close the setting dialogue. Calculating function of power consumption is valid even when 

closing a dialogue. 
④Robot Pull-down list 

Display a list of object robots for power consumption calculation among robots in the project. 
(Figure 5 Pull-down list An object robot for calculation can be selected from the list and the 
selected robot is highlighted. Or, [Not select] can be selected. (Power consumption is not 
calculated with the status that the robot is not selected. 
 
*Calculates only selected robots in the list. 
(Example Drawing 6 shows calculation for R02 [C02] ZX165U-B501.) 
Select [Not selected] when not calculating any robot. 
*Calculation estimates power consumption from the start of the motion program execution to the 
end of that. In case the motion program is executing, it estimates from the robot selection of 
pull-down list to the end of the motion program execution. 
 

 
 

 
Figure 5 Pull-down list 

 
 

 
Figure 6 Robot selection example 

 
Below drawings 7-9 show results display dialogue. When there is a calculated result of power 
consumption, that value is displayed. 
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Figure 7 Results dialogue (Max Current) 

Figure 8 Results dialogue (Average Power) 

Figure 9 Results dialogue (Summary) 
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Refer to the following function of this screen. 
①Max Current tab 
Display step number, joint maximum current for each step (Select with current value [Arms] and 
Capability [%]), step name and program name. 
*Capability means capable value for motor rated current. (Divides current value with rated 
current) 
*Current value means servo motor current of joint (q axis current) and a code is equivalent to the 
rotate direction which is defined to robot joint. 
*For maximum current, the larger value is displayed with ± code as an absolute value. 
②Average Current tab 
Display step number, joint maximum current by step (Select with current value [Arms] and 
Capability [%]), step name and program name. 
*Average current is the simple average of the value. 
③Average Power tab 

Display step number, average power for each step [W], cycle time [sec], step name and program 
name. 
④Summary tab 

Display electric energy and cycle time per a program, and total consuming electric energy of 
whole day (only when selected). 
⑤Show Setting button 

Close the results dialogue and display a setting dialogue. 
⑥Save Results button 

Output displayed joint maximum current etc. as a text file. Refer to chapter 0 for output items. 
⑦Close button 

Close the dialogue. (Calculating function of power consumption is valid even when closing the 
dialogue.) 
⑧Robot Pull-down list 

Display a list of object robots for power consumption calculation among robots in the project. 
Select either robot [Selected] or [Not selected] from the list. Power consumption is not calculated 
with the status that the robot is not selected. 

4.35.3 Parameter 

Below charts 1-4 show parameters required for calculation. Obtain these parameters from each 
applicable default file. Default files are stored in 【K-ROSET install folder】¥system¥plugins. 
Chart 1 Parameter Set as default file PwConsumptionMotor.xml 
Item Unit Explanation 

motorname [－] Motor type (Each joint has value) 
pbcode [－] Power block code (Each joint has value) 
Obtain motor type and power block code using model name and joint number as a key. 

 
Chart 2 Parameter Set as default file PwConsumptionJointParam.xml. 
Item Unit Explanation 

Resistance [Ω] Circuit resistance value for each joint 
RatedCur [Arms] Motor rated current 
Obtain motor type and power block code using model name and joint number as a key. 
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Chart 3 Parameter Set as default file PwConsumptionParam.xml. 
Item Unit Explanation 

CONST_W0 [W] Brake, Control power lost 
muC [μF] Regenerating resistance circuit condenser capacity 
Vlim [V] Voltage threshold of closing regenerating resistance circuit 
Vdef [V] DC voltage applied to the drive system 
Obtain value of chart 3 using model name as a key. 

 
Chart 4 Parameter Set as default file PwConsumptionTable.xml. 
Item Unit Explanation 

PwCalTable Refer to the  
explanation 

Motor TN characteristic 
Rotate number (motor axis) [rpm]-torque (motor axis) [Nm], 
and Rotate number (motor axis) [rpm]-motor current [Arms]  

Obtain value of chart 4 using motor type as a key. 

4.35.4 Output File Format 

Output results as a text file by the results save button of Figure 9. 
Refer to the following output format. 
 
Default output path： 
C:¥Documents and Settings¥【user name】¥My Documents¥MyKHIlibraries¥Projects 
¥【project name】¥【robot name】¥DAT 
*Location of My Documents varies depending on Windows version. 
Default output file name: PwCalData.txt 
Output format: Tab breakpoint 
 
Output items  
Refer to the chart 5. 
Chart 5 Output items 

Item Unit Explanation Remarks 
Program name n/a Program name  
Step number n/a Step number  
Step name n/a Step name  
Maximum current (current 
value)_JT number 

[Arms] Max current for each step 
(Output by JT) 

 

Average current (current 
value)_JT number 

[Arms] Average current for each 
step (Output by JT) 

 

Maximum current 
(capability)_JT number 

[%] 
Max current for each step 
(Output by JT) 

Capability for motor rated 
current 

Average current 
(capability)_JT number 

[%] 
Average current for each 
step (Output by JT) 

Capability for motor rated 
current 

Average electric power [W] 
Average power for each 

step 
 

Cycle time [sec] 
Execution hours for each 
step 
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Only values for each step mentioned in the chart 5 are saved. Results displayed on the summary 
tab are not saved. 
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4.36 Motion Range Display 

Display the motion range of P point of the robot. 
 
*It is impossible to display the motion range at the tool tip. 
*Some models don’t display a part of the range. 
 
Refer to the following method to display. 

1 Add a robot and right-click the robot icon. 
Select Motion Range menu. 

 

2 Click Show to put a check mark. 
Motion range is displayed. Default color is yellow and this color can be changed. 
Click Show and remove a check mark to hide the motion range. 

 

 If there is no motion range model, a menu is not displayed. 

Motion range model doesn’t display interference. 
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4.37 Spot Weld Setting 

This chapter explains about spot weld setting. 
 

4.37.1 Common Items 

 

★ Robot (Controller) 

Select an object robot to be set. 

 Only servo weld gun robots can be selected. 

 

★ OK button 

Save the changed contents and close the dialogue. 

★ Close button 

Delete the changed contents and close the dialogue. 

★ Apply button 

Save the changed contents and continue to set. 
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4.37.2 Simulation Weld Completion Setting 

 

 

★ Input signal type 

Set a time from receiving the weld output signal to outputting the weld completion signal. 
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4.37.3 Clamp Specification 

 

★ Call handling clamp 

Call a dialogue of the handling clamp 

★ Clamp condition code 

Select a clamp condition code to be set. 
Setting contents of the selected code are displayed in [Anticipation of Clamp Output], [Motion 
Start Delay After Weld], [Gun Number], [Clamp Subroutine] and [Clamp Subroutine Number]. 

 With OK or Apply button, only contents of the displayed clamp condition code are saved. 

 

★ Anticipation of Clamp Output 

Set when (how many seconds before a robot reaches to the teach point) to send a gun clamp 
command output to a spot weld gun. 

★ Motion Start Delay After Weld 

Set when (how many seconds after receiving a weld complete signal from a robot weld machine) 
to start moving to a next teach point. 

★ Gun Number 

Set 8 types of guns that can be used for spot weld. Set corresponding data for each gun number on 
the gun setting tab. 

★ Clamp Subroutine 

Select [Used] when not setting a gun. 
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★ Clamp Subroutine Number 

Set subroutine to execute when not setting a gun. 
 

★ Clamp Number 

Select a clamp number to be set. 
Contents of the selected number is displayed on [Weld Control Number] and [Gun Clamp 
Command Output]. 

 With OK or Apply button, only contents of the displayed clamp number are saved. 

 

★ Weld Control Number 

Set 8 types of weld control number that can be connected by spot weld. 

★ Gun Clamp Command Output 

Set a gun clamp command output number to be used. 
 

★ Weld Number 

Select a weld number to be set. 
Contents of the selected number is displayed on [Weld Start Output], [Output Time], [Weld 
Schedule Output Top Signal], [Number of Signal to Use], [Output Format], [Weld Complete Input 
Signal] and [Weld Complete Input Monitor]. 

 With OK or Apply button, only contents of the displayed weld number are saved. 

 

★ Weld Start Output 

Set weld start output signal number for the weld control. 

★ Output Time 

Set output time of the weld start output. This is a level output signal. 

★ Weld Schedule Output Top Signal 

Set the top signal number of weld condition output to weld control. 

★ Number of Signal to Use 

Set number of signal to use for weld schedule output top signal. 

★ Output Format 

Set outputting signals set in [weld schedule output top signal] and [number of signal to use] either 
as binary or as each signal. 

★ Weld Complete Input Signal 

Set input signal number of weld complete that is outputted from weld control to the robot. 

★ Weld Complete Input Monitor 

If weld complete input signal is not inputted within this setting time after weld start output, the 
robot stops by an error. When setting as 0, it doesn’t operate the error detection. 
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4.37.4 Gun Setting 

 

★ Gun Number 

Set a gun number to be set. 
Corresponding setting for the selected gun number is displayed in each item within this tab. 

 With OK or Apply button, only contents of displayed gun number are saved. 

 

★ Upper Limit 

Set the motion stroke 5mm when moving from gun close end to gun open end with a chip of 
abrasion loss zero installed. 

★ Lower Limit 

Set ｜tolerance abrasion loss＋α｜as the lower limit of gun motion. 

★ Motion Direction 

When operating [+] key, match with the actual machine and set “positive” or “negative” in order to 
let the gun operate open motion. 

★ Acceleration Time 

Set time from stop condition to when reaching the max speed. 

★ Max Speed 

Set the max speed. 
 

★ Press Force at Auto Zeroing 
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Set press force when opening the gun to the open end. 

★ Tool Z＋Direction 

Set tool coordinate Z + Direction either close or open. 

★ Press Speed 

At the welding point, press a chip of movable side with this speed until reaching to the set force in 
the last stage of that close motion. 

★ Dressing Force 

Dressing force is not the force of WS code which is taught to that point, but the force for abrasion 
which is set here. 

★ Dressing Time 

Open the gun axis at the time of receiving weld complete signal or passing the dressing time which 
is set here, whichever comes earlier, and move on to the next step. 

★ Clearance Before Force 

Set clearance distance before force with transfer motion to the next welding point. 

★ Clearance After Force 

Robot arm starts moving to the next welding point if the gun opens to the set “Clearance After 
Force.”  
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5  Project Construction 
 

5.1Project Construction Work Flow [ex. Paint] 

 
This section describes the flow of project construction using a flowchart. 

 

  
 
 
 

2. Installation of objects 

3. Creating programs 

4. Outputting a Program 

5. Simulation 

1. Run 

6. Close 
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5.2Installation of objects 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

5.2.1Project setting 

1Select [setting] from project menu. 

2Set the showing origin and initial position dialog. 

Sample (no set) 
 

5.2.2Option setting 

1Select [Option] from [Plug-ins] of menu. 

2Set any term. 
Sample (no set) 
 

Robot 

Obstacle 

Work 

Teach point 

Tool 
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5.3.3Installation of robots 

1Add a robot on the Layout Tab 

2Rename the robot. 

3Change the position of the robot with position dialog. 

4Set showing, locking, and so on. 
 

The other setting of robot 
Set base trans. 
Add tool to select [tool] -> [Load] from robot menu. 
Modify tool trans. 
Set track line. 
Set PC-AS ver. and language in Controller settings. 
Set Posture of Installation and each parameters in Arm settings 

 
Objects File name Image 

Robot KF264-A001 

 

Tool A-BELL 

 
Splay image BellOnPattern_80_01_250 

 

 * Tool KHIlibraries/Tools 
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 * Splay image KHIlibraries/Tools/Paint 

 
 
 
 
 
 
 
 
 
 

Sample: Input [Expand Items] in Arm settings. 
Parameters J1 J2 J3 J4 J5 J6 

Before After 
UP-LIM 150 40 150 90 720 720 410 
LO-LIM -150 -110 -60 -80 -720 -720 -410 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Objects X Y Z RX RY RZ 
Robot 0 0 710 0 0 0 
Tool 0 1708.5 1943.4 -90 0 0 
Splay image 0 2222 1782 -135 0 0 
Trans X Y Z RX RY RZ 
Base 0 0 0 0 0 0 
Tool 0 337.5 689.5 90 45 -90 

Motion range limit of 
J1 
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5.2.4Installation of works 

1Add a workpiece on the Layout Tab 

2Rename the workpiece. 

3Change the position of the workpiece. 

4Set showing, locking, and so on. 
 

Object File name Image 
Workoiece Box_Black_L 

 
* Workpiece KHIlibraries/Envs/SimpleShapes/Boxes 

 
X Y Z RX RY RZ 
0 0 2000 0 0 0 

 

5.2.5Installation of obstacles(Reference)  

1Add an obstacle on the Layout Tab. 

2Rename the obstacle. 

3Change the position of the obstacle. 

4Set showing, locking, and so on. 
 
 
 
 
 
 
 
 
 
 
 

Objects File name Image 
Obstacle Safetyfence_1840_1565 

 

Obstacle Safetyfence_1840_1565 
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* Obstacle: KHIlibraries/Envs/Equipment/Fences 
 

X Y Z RX RY RZ 
1000 0 0 0 0 90 
0 -1000 0 0 0 0 

 

5.2.6Teaching (Reference)  

 

1Add a teaching point. 
Type adding teaching point is as follow. 
 
from Layout Tab. 
Using [Add Point by Current Position]. 
Using [Add Point when Mouse Clicked] 
Using other Plug-ins application (example: Create Painting Program, Create Point of Edge) 

 

2Rename teaching point. 
Sample 

Objects X Y Z RX RY RZ 
Teaching Point 0 2398 1605.9 -135 0 0 
Teaching Point 220 1780 300 180 0 0 
Teaching Point -220 1780 300 180 0 0 
Teaching Point 220 2220 300 180 0 0 
Teaching Point -220 2220 300 180 0 0 
Teaching Point 220 1780 670 180 0 0 

 
 

5.2.7Entry a home position  

1Open dialog to select [Home setting] -> [Move to Home…] in Teach Panel. 

2Input coordinates to entry and Click [Apply]. 
 

5.2.8Setting groups (Reference)   

1Add group. 

2Set objects to group by dragging or using edit function. 
Sample (no set) 
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5.2.9Save a project(Reference) 

1Open project menu from Layout Tab. 

2Select [Project] -> [Save]. 

3Select saving type. 

4Sample (Save as [TestProject] with save speedy) 
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5.3Robot Programming 

 

5.3.1Adding a program (reference) 

 

1Display Program Table Tab. 

2From the Root menu on the program table, select [Application settings]. 

3Set each term. 

4From the ControllerName menu (displayed by right-clicking the area indicated by [C01] 
below), choose the [Add] -> [Program]. 

5Rename new Program on the Program Table. 
 

 

 

5.3.2Adding program instructions 

 
Program instructions are added to the created program in the following three ways. 
 

★ Add one directly on the program table. 

★ Use the TP_PAINT function to add one.  

★ Add one from a teaching point in the project. 
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5.3.2Editing/deleting a program instruction  

For the editing methods of program instructions, the following four are typical. 
 

★ Edit on the program table. 

★ Use the TP_PAINT function to edit the instruction. 

★ Use a text editor to edit the program file (with extension .pg) directly. 

★ Edit the instruction on the real machine (controller) directly. 

Sample 

 
 

5.3.4Saving a program 

1Select [File save] -> [Prgram(*.pg)]from Controller name menu or program name menu. 

2Name the file name in save dialog and save it. 

 * The file name is in explorer. Name displayed on Virtual teach Pendant is program name. 

Sample (Save as [TestProgram.pg]) 

 
 

5.4Simulation  

This chapter describes a method to simulate robot’s operations using prepared projects and AS 
programs, and calculate the cycle time or sense collision to verify operations. 

.PROGRAM Pg001() 
SPRAY_SPEED 1100mm/s 
SPRAY_JSPEED 100% 
AIRCUT_SPEED 1100mm/s 
AIRCUT_JSPEED 100% 
FLOW_RATE 2 
SHAPING 2 
AIRMOTOR 2 
SMOOTH_RANGE 50mm 
JMOVE JOINT 0000,5.365,-5.449,-27.778,-73.52,-26.728,-16.215 
LMOVE XYZ1 0000,220,1780,-410,-180,180,0 
SPRAY #1,ON 
LMOVE XYZ1 0000,220,2220,-410,-180,180,0 
LMOVE XYZ1 0000,-220,2220,-410,-180,180,0 
LMOVE XYZ1 0000,-220,1780,-410,-180,180,0 
SPRAY #1,OFF 
JMOVE JOINT 0000,5.365,-5.449,-27.778,-73.52,-26.728,-16.215 
PGM_SELECT 
.END 
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5.4.1Preprocess(Reference) 

 
Select the tab of a robot name. (Ex.: R01 [C01]) 
Apply project data to PC-AS by selecting [Synchronize] of Controller Tab. 

 * Display Virtual Teach Pendant as appropriate. 

 
Settings various simulation parameters 

 

5.4.2Running a teaching program 

1This section describes the method to execute an AS program. 

Select the Control tab at the bottom of the screen. 

Select the tab of a robot name. 

2Enter the repeat mode[ ](right side).  

3Turn ON the motor [ ](light a lamp). 

4Press the [Load PG] button.. 

5A dialog to choose a file will be opened. Select a program file that you wish to execute. 

6Programs in the program file are listed. Select the target program. 

7Press the [ ] button. 
 
 

To replay the AS programs for multiple robots simultaneously, execute extended applications 
simultaneously. 

 

5.4.3Display cycle time (Reference) 

It is necessary to output the track line file for measuring cycle time. 
 
Making the setting of the [output trajectory file] valid.  
After the program has been normally ended or abnormally ended due to an error etc, the cycle time 
screen will appear. 
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5.5Movie Recording 

This section describes about recording the movie 
 

1Select [Record Video ]from menu. 

2Displaying saving dialog, select the button [Save] after specify file name and path. 

 

3Set compression format and select [OK]. 

4Move the view. 

5Select [Stop Video Record ] and stop the record. 
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6  Appendix 
 

6.1Editor Mode 

This section describes the operation at the time of editor mode. This mode can deal in advanced 
functions in Layout Tab, Property Tab and Program Table. 

 

6.1.1Function in Tree pane 

 

6.1.1.1Add Robot Root 

This adds the tree for robot configuration. 
Adding the joint ,the base and the flange, the robot can set in a variety of different configurations. 
  
In the tree pane, right-click the project icon [ ]. 
In the tree pane, select [Robot Root] -> [Add] from the robot menu. 
* Rename as R**[C**] after robot is set. 
 

6.1.1.2Add Tool 

This adds the model as Tool type. 
In the tree pane, select [Tool] -> [Add] from the robot menu. 
The file selection dialog box will appear. Select the target file, and press the [Open] button. 
 

6.1.1.3Add Adapter 

This adds the adapter of the robot. 
In the tree pane, select [Adapter] -> [Add] from the robot menu. 
 

6.1.1.4Add Robot Base 

This adds the base of the robot. 
In the tree pane, select [Robot Base] -> [Add] from the robot menu. 
The file selection dialog box will appear. Select the target file, and press the [Open] button. 
 

 

6.1.1.5Add Joint 

This adds the joint of the robot. 
In the tree pane, select […Axis] -> [Add] from the robot menu. 
The file selection dialog box will appear. Select the target file, and press the [Open] button. 
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Active Axis 
This becomes operational after the action is set in Properties Tab. 
・Passive Axis 
This becomes operational after Link Formula is set in Properties Tab. 
 
 

6.1.1.6Import 

This adds the model made as the entity type of K-ROSET. 
The robot is added without AS controller. 
*The robot is only imported from only the robot menu.  
Change K-ROSET into the editor mode. 
Right-click an icon, and select [Add] -> [Import] from the menu. 
A dialog will appear. Select a file to import it. 
 

6.1.1.7Export 

This saves the model made as the selected entity type. It also saves tree constitution. 
Change K-ROSET into the editor mode. (To do so, make settings on the basic application GUI 
settings dialog.) (Perform the following in the editor mode in the same manner.) 
In the tree pane, right-click the icon of the data that you wish to export, and select [Export] from 
the menu. 
A dialog will appear. Specify a destination to save data to execute export. 
 

6.1.1.8Reset Location 

Recorded location data is cleared and the model is moved to the position of Local Trans. 
 

6.1.2Function in Properties Tab 

 

(1) Active axis 
Parameter Change Description 

Axis Group O Setting of the inner axis or outer axis as configuration. 
Type O Setting of transfer or revolution and the target axis 
Direction O Setting of positive and negative of action  

 
(2) Passive axis 

Parameter Change Description 
Link Formula O Setting of synchronizing axis 

 

6.1.3The procedures to entry a tool model 

1Add the robot from Tree pane. 

2Select [Editor] from operation mode of Settings on Layout Tab. 
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3The file selection dialog box will appear. Select the target file, and press the [Open] button. 

4The model is shown at the origin. 

（Hisui :*.STL） 

5Hide models except the tool. 

    ( To display only the tool in thumbnail ) 

6Rename the tool entity. 
 
 
 
 
 
 
 
 
 

7Select [Export] from the tool menu.  
 

8A dialog to save files will be displayed. Select the destination folder and the file name to 
be saved, and press the [Save] button. 
*Make the new folder for model before saving the model. 
 

9Select [Batch Operation] -> [Show Model] -> 
[All] from the Project menu to show models. 

 

10Select [Delete] from the tool menu. 
 

11Select [Normal] from operation mode of 
Settings on Layout Tab. 
Select [Tool] -> [Load] from the robot menu and confirm the model. 
The character [T] in thumbnail show to entry the model as Tool. 
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7  FAQ/Troubleshooting 
 

7.1FAQ/Troubleshooting about 

Installation/Start-up 

This chapter describes FAQ/troubleshooting about installation and start-up. 

 
Q1. Can K-ROSET duplicate on a computer? 
A1. It is not possible to doubly start up K-ROSET. Press the [Cancel] button to close the window. 

 
Q2. When language settings are changed in a multi-user environment, multiple languages may be present 
in the environment of a user other than the one who performed the change. 
A2. To start up K-ROSET using the account of a user other than the one who performed the change, 
please set up the language again. 
 
Q3. K-ROSET does not start up when using a user account with only user authority. 
A3. Please grant authority equal to or higher than that of the power user to the user account by which you 
wish to start up K-ROSET. 
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7.2FAQ/Troubleshooting about User Operations 

This chapter describes FAQ/troubleshooting about user operations. 
 
Q1. When I added a teaching point on the tree, I could not add by specifying each joint value. 
A1. On the tree, it is not possible to add a teaching point by specifying each joint value. 
On the program table, however, it is possible to add a teaching point by specifying values to be converted 
or each joint value. 
 
Q2. When more than one model is added from Explorer using the drag-and-drop operation, the sequence 
of the models added onto the tree (Work1, Work2, ...) does not match the sequence viewed on Explorer. 
A2. To match the sequence between the view of Explorer and the tree, please select a file and add it one 
by one. 
 
Q3. When using hand-grip teaching, I can’t tell when objects are interfering with each other. 
A3. The interference checking function is not valid when using hand-grip teaching. 
 
Q4. When a robot or a workpiece is moved by the drag-and-drop operation while holding the Ctrl key, the 
part is duplicated, but it is not displayed on the tree. 
A4. The current version does not support duplication performed by pressing the Ctrl key. Please do not 
execute this operation. 
 
Q5. When simulation is executed repeatedly, the size of the project file increases when it is saved. 
A5. The size of the project file increases by the size of the drawn trajectory lines when simulation is 
executed repeatedly. 
By saving a project file after deleting the trajectory lines, it is able to avoid this phenomenon of increased 
size can be avoided. 
 
Q6. As the number of robots in a project increases, the size of the project file increases when it is saved. 
A6. For the current version, the more robots contained in a project, the more the size of the project file 
increases. 
When there is a robot which is no longer used in a project, delete the robot and then save the project. 
 
Q7 When movie-capturing is executed during simulation, the execution speed of simulation decreases. 
A7 Since the machine is overloaded during simulation, simultaneous execution of movie-capturing with 
simulation will cause some impacts. 
It is recommended to capture movies when the machine is executed on a timeline basis. 
  
Q8. When a program is read in with the view rotated, the view is rotated again after the read-in. 
A8. By reading in a program after canceling the rotational state, the view is not rotated after the read-in. 
In addition, since this phenomenon does not occur when the view is rotated with the wheel pressed, it is 
recommended to change the direction of the view by this method. 
 
Q9. The edges of the grid displayed on the view do not appear. 
A9. Because of K-ROSET’s restrictions, the edges of the grid may not be displayed when the display 
range of the grid is enlarged. 
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They may be displayed correctly when the angle of the view is changed or the display range of the grid is 
reduced. 
 
Q10. When I tried to execute simulation, the message “The X-axis shows abnormal deviation” is 
displayed, so that simulation cannot be executed correctly. 
A10. Simulation cannot continue by default while interference is being caused among the models. 
By unchecking the item below on the Option Settings screen, simulation can be executed even while 
models are interfering with each other. 

 

 
 

 
Q11. When a character is entered in a property item, “xx is not a valid value of the Double attribute ” is 
displayed. 
A11. Such a message is displayed when a character is entered in an item to which only numerical values 
are allowed. 
 
Q12.In the case of using same target file, when shape of the file is changed, previous saved project is also 
applied. 
A12. When shaping is changed, Please export and added it on the view. 
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7.3Restrictions 

- Restriction on the project 
When saving a project, it is not allowed to enter a project name whose absolute path name on the 
Windows system exceeds 255 bytes. 
 
- Restriction on the robot 
The maximum number of robots which can be added to a project is eight. 
 
- Restriction on the direct teaching grip display 
When a perspective view of the screen is being displayed, it is not possible to reposition the end of the 
robot’s hand using the direct teaching grip display function. 

 
• Restrictions on message that it is displayed when K-ROSET is quitted 
Application will be displayed  "Do you want to save changes" after you save the project, even if you do 
not have change operation. Message has to be always displayed at the end of the current 
situation for prevention, forgotten save. 
If the save operation before the end, the fix has been reflected a 
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